classification_sample_async.exe not found

classification_sample_async.exe not found


Hi,

I've been trying to install the OpenVino toolkit on my laptop running on windows 10 from the past days and after troubleshooting a number of error that kept coming one after another, i'm can't seem to find a way around this one - 

The system cannot find the path specified.
classification_sample.exe -i "D:\program files\openvino_2019.3.379\deployment_tools\demo\car.png" -m "C:\Users\home\Documents\Intel\OpenVINO\openvino_models\ir\FP32\classification\squeezenet\1.1\caffe\squeezenet1.1.xml" -d CPU
'classification_sample.exe' is not recognized as an internal or external command,
operable program or batch file.

Also there are no files at- C:\Users\home\Documents\Intel\OpenVINO\inference_engine_demos_build\intel64\Release\

Any help would be greatly appreciated.

32 posts / 0 new

Hi trivedi, jayesh

I am sorry to hear you are running into issues with the install. May I ask if you have verified your installation using the verification scripts? If you haven't done so I would strongly recommend verifying your installation before moving forward.

"Also there are no files at- C:\Users\home\Documents\Intel\OpenVINO\inference_engine_demos_build\intel64\Release\": For this error you may need to build the examples which is the reason why the folder is empty. Please run the build_demos_msvc.bat script under C:\Program Files (x86)\IntelSWTools\openvino\inference_engine\demos, don't forget to source the environment vars before building the samples (C:\Program Files (x86)\IntelSWTools\openvino\bin\setupvars.bat).

Hope this helps, let us know if you have any issues.

 

Regards,

Luis


Thanks for replying Luis.

I'm facing this error when trying to run the verification scripts.

The system cannot find the path specified.
classification_sample.exe -i "D:\program files\openvino_2019.3.379\deployment_tools\demo\car.png" -m "C:\Users\home\Documents\Intel\OpenVINO\openvino_models\ir\FP32\classification\squeezenet\1.1\caffe\squeezenet1.1.xml" -d CPU
'classification_sample.exe' is not recognized as an internal or external command,
operable program or batch file.

I tried running the build_demos_msvc.bat script but it keeps saying that i don't have the build tools for visual studio installed although they are already installed.


Hi Jayesh,

Could you confirm you have installed the required dependencies as mentioned in the Getting Started Guide for OpenVINO Toolkit for Windows 10?

Microsoft Visual Studio* with C++ 2019, 2017, or 2015 with MSBuild

CMake 3.4 or higher 64-bit

Python 3.6.5 64-bit

Regards,

Jesus 


Thanks for replying Jesus.

I've installed all the required dependencies as mention in the getting started guide. I have Microsoft Visual Studio 2015 with MSBuild and all build tools

I also have python 3.7.3 and Cmake 3.16 installed.

Should i just remove and reinstall everything...?

Regards 

Jayesh


Hi Jayesh,

Could you try downgrading your python to version 3.6.5 64-bit version? Also, try to setup the environment variables permanently as mentioned in the following guide: https://www.intel.com/content/www/us/en/support/articles/000033440/board...

Regards,

Jesus


Hey Jesus,

I followed your instructions and downgraded my python to version 3.6.5 and permanently set up the environment variables.

But again i face the same errors

The system cannot find the path specified.
classification_sample.exe -i "D:\program files\openvino_2019.3.379\deployment_tools\demo\car.png" -m "C:\Users\home\Documents\Intel\OpenVINO\openvino_models\ir\FP32\classification\squeezenet\1.1\caffe\squeezenet1.1.xml" -d CPU
'classification_sample.exe' is not recognized as an internal or external command,
operable program or batch file.

While running the verification script and 

Build tools for Microsoft Visual Studio  cannot be found. If you use Visual Studio 2017, please download and install build tools from https://www.visualstudio.com/downloads/#build-tools-for-visual-studio-2017

While running build_demos_msvc.bat.

Regards

Jayesh


Hi Jayesh,

Did you install Microsoft Build Tools 2015? I'm currently installing Microsoft Visual Studio 2015 and I noticed it does not include the build tools. Alternatively you can try installing the latest Microsoft Visual Studio 2019.

I will let you now what I find out once my installation completes. 

Regards,

Jesus


Hi Jayesh,

It looks like the build samples script file is not properly detecting Microsoft Visual Studio 2015. I will open a bug for the development team to take a look. In the meantime, could you try to install Microsoft Visual Studio 2017 or 2019?

Regards,

Jesus


Hey Jesus,

I'll install try Installing Microsoft Visual Studio 2017 and let you know the results.

Regards,

Jayesh


Hey Jesus,

I removed Visual Studio 2015 and installed Visual Studio 2017 and now i'm facing a new error while running the verification scripts.

It says - 

Creating Visual Studio  x64 files in C:\Users\JacK\Documents\Intel\OpenVINO\inference_engine_samples_build...
CMake Error: Could not create named generator Visual Studio

I have the desktop development with c++ workload installed with Visual Studio.

Regards 

Jayesh


Hi Jayesh,

That is very strange, I just installed Microsoft Visual Studio 2017 with Desktop development with C++, Universal Windows Platform development, and MSBuild. I have CMake version 3.16.2 and Python 3.7.4 installed, the build_samples_msvc.bat script completed without any issues. Could you check the Microsoft Visual Studio installed correctly with the components mentioned above?

I apologize for all the trouble with the installation processes.

Regards,

Jesus


Hey Jesus,

I reinstalled my Visual studio 2017, I ran the build_samples_msvc.bat and it ran successfully but when i tried to run verification scripts it again gives the same error - 

CMake Error: Could not create named generator Visual Studio

Since build_samples_msvc.bat has run successfully now, do you think rolling back to visual studio 15 may work..?

As with visual studio 15 the problem was classification_sample_async.exe was not found and you said that it was because build_samples_msvc.bat was not able to run.

What do you think..?

Regards 

Jayesh


Hi,

In new versions it seems that the description in site:https://docs.openvinotoolkit.org/latest/_docs_IE_DG_Samples_Overview.html#build_samples_windows does not match.The paths and folders were changed. 

 

 Can you please explain how I can run a model in GPU with camera in real time? I use Open VINO for windows.

I want to connect camera and run model in real time.  

Thanks and regards in advance,

Hanna


My softwares are:

Visual studio 2019,python 3.6.5 and Cmake 3.14.7

Thanks and regards in advance :-)

Hanna

 


Hi Jayesh,

I am not sure why you are seeing this error, from what I can tell you have everything setup correctly. Any chance you have Cygwin installed? I found a similar error caused by the cmake included with Cygwin. Do you have another system you can try the installation? 

I would stay on Microsoft Visual Studio 2017 as we did not get any more errors building the samples.

Regards,

Jesus


Hi Hanna,

The issue you are seeing is different than the issue on this thread. I noticed you opened a separate thread, I will help you on the other thread.

Regards,

Jesus


Hey Jesus,

Unfortunately i don't have cygwin installed on my system and nor do i have any other windows system But i do have a raspberry pi lying around.

I've reinstalled the softwares again and again but can't seem to find my way around this problem.

Regards,

Jayesh


Hi Jayesh,

Could you try running the following command and attaching a text file containing all the text you see in the command line?

"C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\demo_squeezenet_download_convert_run.bat"

Please also run the following commands after you run the previous command and provide the output. 

echo %PATH%
cmake --version
python --version
"C:\Program Files (x86)\Microsoft Visual Studio\Installer\vswhere.exe"

Regards,

Jesus


Hey Jesus,

I reinstalled visual studio 17, Cmake and openvino toolkit, this solved the CMake Error: Could not create named generator Visual Studio error,

but when i ran the demo_squeezenet_download_convert_run.bat script it gave me the error 'classification_sample_async.exe' is not recognized as an internal or external command.

It wasn't solved even after running build_demos_msvc.bat which ran successfully but with 5 wanings.

I'm attaching text files showing command line result after running the demo_squeezenet_download_convert_run.bat script, build_demos_msvc script as well as after running the commands you asked.

Thanks & Regards

Jayesh

Attachments: 


Hi Jayesh,

Thanks for providing the results of the commands requested, all came out as expected. Let's keep that software configuration as it seems to all be working with the exception of the verification script.

The script cannot find the classification_sample_async.exe, could you try deleting all the content of C:\Users\JacK\Documents\Intel\OpenVINO\ and run the verification script again to force the script to rebuild it. Please send me a new log when you run the verification script. 

Could you also try running the demo_security_barrier_camera.bat verification script? 

Regards,

Jesus


Hey Jesus,

I deleted all the contents of C:\Users\JacK\Documents\Intel\OpenVINO\ and ran the verification scripts, but i again faced the same error. Even the demo_security_barrier_camera.bat script is showing similar error.

Where should the classification_sample_async.exe be located..? 

I searched my system and it is located in 

D:\program files\intel open vino\openvino_2019.3.379\deployment_tools\inference_engine\samples\intel64\Release

I've attached the logs after running both verification scripts.

Thanks & Regards

Jayesh

 

Attachments: 


Best Reply

Hi Jayesh,

Thanks for providing the logs. Based on the information there, I can see that there is a space in the path of the samples (D:/program files/intel open vino/openvino_2019.3.379/deployment_tools/inference_engine/samples). I have reproduced this issue on a different thread (here) of a user who reported something similar, our suggestion was as follows:

Quote:

Luis_at_Intel (Intel) wrote:

...there seems to be an issue when there is a space in the models path. I am able to reproduce and its seems to be a bug in the demo script.

"Please edit the demo_squeezenet_download_convert_run.bat file under C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\ directory and make it look like this:

# line #102:
python "%downloader_dir%\downloader.py" --name "%model_name%" --output_dir "%models_path%" --cache_dir "%models_cache%"

# line #107:
if exist "%ir_dir%" (

You may need to modify the file as Administrator to be able to save the changes...

 

Let me know if the problem persists afterwards, I hope this resolves it. 

Regards,

Luis


Hey luis,

In the demo_squeezenet_download_convert_run.bat file the lines 102 and 107 were the same as the changes you asked me to make. I changed the folder name from intel open vino to intel_open_vino. Still nothing changed.

Thanks & Regards 

Jayesh


Hi Jayesh,

The changes may not look the same but there are double quotes missing around the parameters for both lines of code; for example in line #107 if exist ir_dir is missing double quotes around ir_dir, so it should be if exist "ir_dir". I would suggest to double check and make sure quotes are found there, this should take care of the issue with spaces and allow to have spaces in path. 

I assume the path is still an issue as there is another space before intel_open_vino in "program files" (D:/program files/intel open vino/openvino_2019.3.379/deployment_tools/inference_engine/samples). The double quotes as mentioned above should take care of it, spaces shouldn't be an issue once double quotes are added.

 

Regards,

Luis


Hey Luis,

Thanks for pointing out that I needed to add double quotes in lines 102 and 107, unfortunately, adding them didn't work either and I'm still stuck with the same error.

Thanks & Regards

Jayesh


Hi Jayesh,

Did you also add on line #102 quotes around each of %downloader_dir%\downloader.py, %model_name%, %models_path% and %models_cache%?

python "%downloader_dir%\downloader.py" --name "%model_name%" --output_dir "%models_path%" --cache_dir "%models_cache%".

If the error persists, please provide the log of what you see and also the .bat script you have modified. 

 

Regards,

Luis

 


Hey Luis,

The problem is still here. I've attached the files the modified .bat script as well as the log after running the script.

Thanks and Regards

Jayesh

Attachments: 

AttachmentSize
Downloadtext/plain log.txt6.68 KB
Downloadtext/plain modified script.txt8.57 KB

Hi Jayesh,

Thanks for the info. Could you please try deleting the folder "C:\Users\JacK\Documents\Intel\OpenVINO\openvino_models" with all of its contents and re-run? I believe one thing that may be giving issues is that your installation of OpenVINO is installed in a path where there is a space, according to the log.txt, INTEL_OPENVINO_DIR is set to "D:\program files\intel_open_vino\openvino_2019.3.379".

Let me attempt to install the OpenVINO Software under a similar directory and let you know the results. My guess is that there is another bug in the demo scripts, and it "errors out" when the OpenVINO software is installed on a path with a space in it. I will get back to you shortly. 

 

Regards,

Luis


Hi Jayesh

 

I used to install openvino in directory D:\xxx\openvino and faced the exact same problem with you.

The problem was somehow solved by re-installing openvino into the default directory (i.e. C:\Program Files (x86)\IntelSWTools\openvino)

and then everything works fine. Hope it helps.

 

Regards.

Caleb


Hi Jayesh,

I have tested installing the software in a similar directory and I still don't see the issue you do, everything works as expected with the script changes I previously mentioned. I am not sure what else to suggest besides removing the software and reinstalling again, maybe this time in the default directory if possible.

Keep in mind the scripts may need to be updated again (as mentioned before to take care of the spaces in your path). Make sure to install all pre-requisites, run the setupvars.bat, modify the demo script for the quotes on lines 102, 107 and save changes, etc.. Let me know if you have any questions throughout the process. 

 

Regards,

Luis

 


Hey Luis,

Thank you so much for your help, I'll be using my friend's laptop to run OpenVino. 

Regards

Jayesh

Leave a Comment

Please sign in to add a comment. Not a member? Join today