Error in Loading Pre-Trained Models

Error in Loading Pre-Trained Models


Hello. I get an error in downloader.py when downloading models. 

 

samed@SamedBll:/opt/intel/openvino/deployment_tools/open_model_zoo/tools/downloader$ python downloader.py --name human-pose-estimation-0001
  File "downloader.py", line 61
    reporter.print("Will retry in {} seconds...", retry_delay, flush=True)
                 ^
SyntaxError: invalid syntax

#I just want to change the Python version.

samed@SamedBll:/opt/intel/openvino/deployment_tools/open_model_zoo/tools/downloader$ python3 downloader.py --name human-pose-estimation-0001
Traceback (most recent call last):
  File "downloader.py", line 22, in <module>
    import requests
ModuleNotFoundError: No module named 'requests'
samed@SamedBll:/opt/intel/openvino/deployment_tools/open_model_zoo/tools/downloader$ 

I'm open to your suggestions. Thank you.

2 posts / 0 new

Best Reply

I downloaded the requests module but it didn't work in the default python version. I checked of the Requests module on all version Python. Worked on Python3.6. 

sudo python3.6 downloader.py --name human-pose-estimation-0001

is worked.

Problem is solved.

Leave a Comment

Please sign in to add a comment. Not a member? Join today