Error run an openvino model with vpu

Error run an openvino model with vpu


I am not using :

windows 10 os
cpu i3-3220
vpu EDL-mPCLe-MA2485

t use : demo_squeezenet_download_convert_run.bat -d MYDIAD

I encountered an error :

target = MYDIAD

target_precision = FP16

ECHO is off.

PYTHONPATH=C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\open_model_zoo\tools\accuracy_checker;C:\Program Files (x86)\IntelSWTools\openvino\python\python3.6;C:\Program Files (x86)\IntelSWTools\openvino\python\python3;C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\model_optimizer;

[setupvars.bat] OpenVINO environment initialized

INTEL_OPENVINO_DIR is set to C:\Program Files (x86)\IntelSWTools\openvino

ECHO is off.

Requirement already satisfied: pyyaml in c:\users\long\appdata\local\continuum\anaconda3\lib\site-packages (from -r C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\..\open_model_zoo\tools\downloader\requirements.in (line 1)) (3.12)

Requirement already satisfied: requests in c:\users\long\appdata\local\continuum\anaconda3\lib\site-packages (from -r C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\..\open_model_zoo\tools\downloader\requirements.in (line 2)) (2.18.4)

Requirement already satisfied: chardet<3.1.0,>=3.0.2 in c:\users\long\appdata\local\continuum\anaconda3\lib\site-packages (from requests->-r C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\..\open_model_zoo\tools\downloader\requirements.in (line 2)) (3.0.4)

Requirement already satisfied: idna<2.7,>=2.5 in c:\users\long\appdata\local\continuum\anaconda3\lib\site-packages (from requests->-r C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\..\open_model_zoo\tools\downloader\requirements.in (line 2)) (2.6)

Requirement already satisfied: urllib3<1.23,>=1.21.1 in c:\users\long\appdata\local\continuum\anaconda3\lib\site-packages (from requests->-r C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\..\open_model_zoo\tools\downloader\requirements.in (line 2)) (1.22)

Requirement already satisfied: certifi>=2017.4.17 in c:\users\long\appdata\local\continuum\anaconda3\lib\site-packages (from requests->-r C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\..\open_model_zoo\tools\downloader\requirements.in (line 2)) (2019.11.28)

Download public squeezenet1.1 model

python "C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\open_model_zoo\tools\downloader\downloader.py" --name "squeezenet1.1" --output_dir "C:\Users\Long\Documents\Intel\OpenVINO\openvino_models\models" --cache_dir "C:\Users\Long\Documents\Intel\OpenVINO\openvino_models\cache"

################|| Downloading models ||################

 

========== Retrieving C:\Users\Long\Documents\Intel\OpenVINO\openvino_models\models\public\squeezenet1.1\squeezenet1.1.prototxt from the cache

 

========== Retrieving C:\Users\Long\Documents\Intel\OpenVINO\openvino_models\models\public\squeezenet1.1\squeezenet1.1.caffemodel from the cache

 

################|| Post-processing ||################

 

========== Replacing text in C:\Users\Long\Documents\Intel\OpenVINO\openvino_models\models\public\squeezenet1.1\squeezenet1.1.prototxt

squeezenet1.1 model downloading completed

 

Waiting for 5 seconds, press a key to continue ...

 

Target folder C:\Users\Long\Documents\Intel\OpenVINO\openvino_models\ir\public\squeezenet1.1\FP16 already exists. Skipping IR generation with Model Optimizer.

If you want to convert a model again, remove the entire C:\Users\Long\Documents\Intel\OpenVINO\openvino_models\ir\public\squeezenet1.1\FP16 folder.

 

Waiting for 7 seconds, press a key to continue ...

 

###############|| Generate VS solution for Inference Engine samples using cmake ||###############

 

 

Waiting for 2 seconds, press a key to continue ...

Creating Visual Studio 15 2017 x64 files in C:\Users\Long\Documents\Intel\OpenVINO\inference_engine_samples_build...

-- Selecting Windows SDK version 10.0.17763.0 to target Windows 10.0.18362.

-- The C compiler identification is MSVC 19.16.27038.0

-- The CXX compiler identification is MSVC 19.16.27038.0

-- Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio/2017/Professional/VC/Tools/MSVC/14.16.27023/bin/Hostx86/x64/cl.exe

-- Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio/2017/Professional/VC/Tools/MSVC/14.16.27023/bin/Hostx86/x64/cl.exe - works

-- Detecting C compiler ABI info

-- Detecting C compiler ABI info - done

-- Detecting C compile features

-- Detecting C compile features - done

-- Check for working CXX compiler: C:/Program Files (x86)/Microsoft Visual Studio/2017/Professional/VC/Tools/MSVC/14.16.27023/bin/Hostx86/x64/cl.exe

-- Check for working CXX compiler: C:/Program Files (x86)/Microsoft Visual Studio/2017/Professional/VC/Tools/MSVC/14.16.27023/bin/Hostx86/x64/cl.exe - works

-- Detecting CXX compiler ABI info

-- Detecting CXX compiler ABI info - done

-- Detecting CXX compile features

-- Detecting CXX compile features - done

-- Found InferenceEngine: C:/Program Files (x86)/IntelSWTools/openvino/deployment_tools/inference_engine/lib/intel64/Release/inference_engine.lib (Required is at least version "2.1")

-- Configuring done

-- Generating done

-- Build files have been written to: C:/Users/Long/Documents/Intel/OpenVINO/inference_engine_samples_build

 

Waiting for 7 seconds, press a key to continue ...

 

###############|| Build Inference Engine samples using MS Visual Studio (MSBuild.exe) ||###############

 

 

Waiting for 3 seconds, press a key to continue ...

"C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\MSBuild\15.0\Bin\MSBuild.exe" Samples.sln /p:Configuration=Release /t:classification_sample_async /clp:ErrorsOnly /m

Microsoft (R) Build Engine version 15.9.21+g9802d43bc3 for .NET Framework

Copyright (C) Microsoft Corporation. All rights reserved.

 

 

Waiting for 7 seconds, press a key to continue ...

 

###############|| Run Inference Engine classification sample ||###############

 

 

Waiting for 3 seconds, press a key to continue ...

        1 file(s) copied.

classification_sample_async.exe -i "C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\car.png" -m "C:\Users\Long\Documents\Intel\OpenVINO\openvino_models\ir\public\squeezenet1.1\FP16\squeezenet1.1.xml" -d MYDIAD

[ INFO ] InferenceEngine:

        API version ............ 2.1

        Build .................. 37988

        Description ....... API

[ INFO ] Parsing input parameters

[ INFO ] Parsing input parameters

[ INFO ] Files were added: 1

[ INFO ]     C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\car.png

[ INFO ] Creating Inference Engine

[ ERROR ] Device with "MYDIAD" name is not registered in the InferenceEngine

Error

can i run openvino on only vpu? and how to run it? help me ? thanks

3 posts / 0 new

You misspelled MYRIAD as MYDIAD. Use "-d MYRIAD" instead.

Note: Do you have an Intel Neural Compute Stick or Neural Compute Stick v2 plugged into a USB port of your machine? I'm not sure that the MYRIAD option works for the embedded Myriad X device that you have onboard. You may need to try "-d HDDL" instead.

R. Michael Pickering CBIP

Hi Michael

 

when I use d MYRIAD I encountered an error :

[ INFO ] InferenceEngine:
        API version ............ 2.1
        Build .................. 37988
        Description ....... API
[ INFO ] Parsing input parameters
[ INFO ] Parsing input parameters
[ INFO ] Files were added: 1
[ INFO ]     C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\car.png
[ INFO ] Creating Inference Engine
        MYRIAD
        myriadPlugin version ......... 2.1
        Build ........... 37988

[ INFO ] Loading network files
[ INFO ] Preparing input blobs
[ WARNING ] Image is resized from (787, 259) to (227, 227)
[ INFO ] Batch size is 1
[ INFO ] Loading model to the device
[ ERROR ] Can not init Myriad device: NC_ERROR
Error

when I use d HDDL I encountered an error :

[ INFO ] InferenceEngine:
        API version ............ 2.1
        Build .................. 37988
        Description ....... API
[ INFO ] Parsing input parameters
[ INFO ] Parsing input parameters
[ INFO ] Files were added: 1
[ INFO ]     C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\demo\car.png
[ INFO ] Creating Inference Engine
        HDDL
        HDDLPlugin version ......... 2.1
        Build ........... 37988

[ INFO ] Loading network files
[ INFO ] Preparing input blobs
[ WARNING ] Image is resized from (787, 259) to (227, 227)
[ INFO ] Batch size is 1
[ INFO ] Loading model to the device
[09:33:13.7724][7108]I[main.cpp:243] ## HDDL_INSTALL_DIR: C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\inference_engine\external\hddl
[09:33:13.7875][7108]I[main.cpp:245] Config file 'C:\Program Files (x86)\IntelSWTools\openvino\deployment_tools\inference_engine\external\hddl/config/hddl_service.config' has been loaded
[09:33:13.7898][7108]I[filehelper.cpp:272] Set file:/var/tmp/hddl_service_alive.mutex owner: user-'no_change', group-'users', mode-'0660'
[09:33:13.7904][7108]I[filehelper.cpp:272] Set file:/var/tmp/hddl_service_ready.mutex owner: user-'no_change', group-'users', mode-'0660'
[09:33:13.7914][7108]I[filehelper.cpp:272] Set file:/var/tmp/hddl_start_exit.mutex owner: user-'no_change', group-'users', mode-'0660'
[09:33:13.7957][7108]I[autobootstarter.cpp:156] Info: No running autoboot process. Start autoboot daemon...
[09:33:14.8566][7108]I[autobootstarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 1 seconds ...
[09:33:15.8619][7108]I[autobootstarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 2 seconds ...
[09:33:16.8664][7108]I[autobootstarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 3 seconds ...
[09:33:17.8707][7108]I[autobootstarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 4 seconds ...
[09:33:18.8758][7108]I[autobootstarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 5 seconds ...
[09:33:19.8804][7108]I[autobootstarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 6 seconds ...
[09:33:20.8855][7108]I[autobootstarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 7 seconds ...
[09:33:21.8923][7108]I[autobootstarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 8 seconds ...
[09:33:22.8976][7108]I[autobootstarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 9 seconds ...
[09:33:23.9034][7108]I[autobootstarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 10 seconds ...
[1;31;40m[09:33:23.9037][7108]ERROR[autobootstarter.cpp:89] Error: Service wait Autoboot to get ready failed due to timeout after 10 seconds.[0m
[1;36;40m[09:33:23.9065][7108]W[autobootstarter.cpp:99]
      ** Suggestion: The timeout by default is 10 seconds, and you can increase it by following steps:
            (1) Add following entry in $HDDL_INSTALL_DIR/config/hddl_service.config like this:
                   "service_settings":
                   {
                     "autoboot_boot_timeout_sec":   10,
                      ...
                   }
            (2) Change the '10' to a larger value to increase the time out window, then try again.
[0m
[1;31;40m[09:33:23.9076][7108]ERROR[autobootstarter.cpp:49] Error: Failed to start autoboot[0m
[1;31;40m[09:33:23.9084][7108]ERROR[main.cpp:76] Error: Start Service failed due to autoboot failure[0m
[1;31;40m[09:33:23.9093][7108]ERROR[subprocess.cpp:118] Error: poll() failed[0m
[1;31;40m[09:34:54.1564][8596]ERROR[servicestarter.cpp:55] Error: Wait HDDL Service Ready failed.[0m
[1;31;40m[09:34:54.1814][8596]ERROR[servicestarter.cpp:29] Error: Failed to start HDDL Service[0m
[1;31;40m[09:34:54.1829][8596]ERROR[hddlclient.cpp:256] Error: Failed to boot service.
[0m
[ ERROR ] _client->query(QUERY_TYPE_DEVICE, &query) failed: HDDL_NOT_INITIALIZED
Error

i use vpu EDL-mPCLe-MA2485 into m2 on main

Leave a Comment

Please sign in to add a comment. Not a member? Join today