Run mask_rcnn on Myriad

Run mask_rcnn on Myriad


When I run mask_rcnn_inception_v2 on Myriad, the result is strange.
It happens with OpenVINO2020.2.
OpenVINO2020.1 gives correct results.(The result is the same as CPU or GPU.)

 

Where to get the model

https://github.com/tensorflow/models/blob/master/research/object_detecti...

mask_rcnn_inception_v2_coco

 

I hope it will be fixed in the next version.

AttachmentSize
Downloadapplication/zip mask_rcnn_inception_v2.zip29.18 MB
5 posts / 0 new

Hi taka,

Thanks for reaching out.

Could you please tell us which sample/demo are you using? Also, provide us with the Model Optimizer command you used to convert the frozen model to IR format.

Regards, 

David


hi DevidC

■demo

mask_rcnn_demo.exe -d MYRIAD -m mask_rcnn_inception_v2.xml -i test.jpg

■Model Optimizer command

mo_tf.py^
 --input_model frozen_inference_graph.pb" ^
 --tensorflow_object_detection_api_pipeline_config pipeline.config ^
 --data_type FP16 ^
 --batch 1 ^
 --tensorflow_use_custom_operations_config ".\extensions\front\tf\mask_rcnn_support.json" ^
 --reverse_input_channel

Regards, 


Hi taka,

Thank you for your reply.

This demo is not supported on VPU devices, that is why it may or may not work. You can check the Readme.md in the demo directory here: mask_rcnn_demo.

Best regards,

David


Hi Devid

I understand that it is not supported by NCS2.
However, since it worked on OpenVINO2020.1, I hope it will be supported someday!

Best Regards,

Leave a Comment

Please sign in to add a comment. Not a member? Join today