IFC and Redhat 9

62 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Thanks Joe; can anyone use this fix with -static? -Lance

PS just curious, any special steps to use a ~/.ifcrc ? Just creating one didn't seem to work. I'll stick with an alias line in my .bashrc for now

There's an ifc.cfg file in the compiler70/ia32/bin directory that can be used to change compiler default options.


Unfortunately, there's much more to RH9 compatibility than the ctype_b issue discussed above. In particular, there's a major change in the pthreads implementation. It's hoped to support RH9 in the next major compiler version, but release of that is a few months away.


> Hi,
> I just upgrade to RedHat 9 and try to compile my
> fortran stuff with Intel Fortran Compiler 7.1. But I
> got some error message as:
> my_intel_location/compiler70/ia32/lib/libIEPCF90.a(f90
> ioerr.o)(.text+0x4d3): In function `f_f77ioerr':
> : undefined reference to `__ctype_b'
> What's the problem?
> jl_wu


I met the same problem. I solved it this way:
at the link step i added : -i_dynamic, in order to use shared libraries instead of archives ones (.a)

I hope it will work


Well that was simple, wasnt it :-)

Confirming, works for me, RH9. Thanks.

> ifc -V
Intel Fortran Compiler for 32-bit applications, Version 7.1 Build 20030402Z

I'm using RH9 and am linking with libc-2.2.93.so with ifc Version 7, build 20021028Z. Compilation and link is fine. I get runtime error: "Incorrectly built binary which accesses errno, h_errno or _res directly. Needs to be fixed."

Program seems to run and gives correct answers. Since I have one of the last free, non-commercial versions, I guess I'll live with it unless someone can tell me how to fix it. Thanks.


My lab just upgraded to RH9 and ifc 6.0 and 7.0 both seem to be able to operate on their own without much of a problem. I am however having trouble linking objects generated with ifc into C/C++ programs I am developing. It would appear that the name mangling standards used by gcc for object files has changed from 2.2x to 3.x.

I was wondering if there is a patch (I can only hope) that will changed the way ifc mangles the function names in the objects in order to be compatible with the standard used by gcc 3.x. If not, is there any discussion among developers for releasing a solution any time in the near future?


gcc doesn't have a standard for the name mangling used by Fortran compilers other than g77. ifc, and other commercial Fortrans, don't use the g77 default convention. It's not clear to me what you are asking for. ifc uses the lower case name, single appended underscore convention, as you'll see if you try out nm.

There is a very simple solution to bypass the problem

use for link : ifc -i_dynamic


I tried this simple solution; the compilation proceeded okay, but I get errors at run-time (see below). Any clues how to work around this problem ?


$>ifc -i_dynamic topo-sasia-subset.f
main program

9 Lines Compiled
a.out: relocation error: /opt/intel/compiler70/ia32/lib/libIEPCF90.so.3: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference


Leave a Comment

Please sign in to add a comment. Not a member? Join today