Address Error

Address Error

I have encountered some sort "Address Error" when I run my program compiled by ifc V7.1 Build 20030307Z with GNU ld 20030206 on a RedHat 7 machine.

When I compile with -g option, there is no "Address Error" and the program runs fine. When I copile without -g option, the "Address Error" appears. With -d2 option, I'm able to locate where the diagonostic enters. It was DGEORF of the LAPACK. By the way, I'm also using the Math Kernel Lib from Intel.

I've tried both -O0 and -O2 option. The Address Error occurs in both case.

I'm very puzzled. Also, followed the suggestion on this forum, I'm using old glibc and libthread from RedHat 8.

Thanks for you help!

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

sorry. made a typo in the message. I meant I'm running on a RedHat 9 machine.

Can you test this on an RH7 or RH8 system? If this reproduces the problem, please submit it to Otherwise, it's hard to do much until there is a compiler version which supports RH9.


Leave a Comment

Please sign in to add a comment. Not a member? Join today