output formatting problem

output formatting problem

This is a first-time posting for me. I couldn't find any obvious way to report an apparent bug, so I hope this route will work.

Anyway, the Intel Fortran Compiler 7.0 for Linux misaligns the columns when the SP edit descriptor is used and the quantity just happens to be zero. Here's example output:

 0.100000 -10.0000  03 17 18.19   +20 23 49.5
 0.100000  0.0000   03 16 26.61   +20 15 48.8
 0.100000 +10.0000  03 15 45.83   +20 09 27.6

Note how the ^ decimal points above the caret do not line up.
5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Information on bug reporting should have been provided with your copy of Intel Fortran. If you have registered with support, go to https://premier.intel.com/ If not, go here Even non-commercial users can register with support and submit bug reports.

Steve

Steve - Intel Developer Support

Okay, I'll try that route. However, it's worth mentioning that I am not the administrator for the system in question. All I was told was the path to the executable. Nobody told me about any information on bug reporting. I would expect that to be a generic problem with multi-user installations. Trouble is, most of the other users on this system program in C, which leaves the few Fortran users fending for ourselves.

As I feared, the whole process of trying to report a simple bug has turned into a major headache. I tried to register as an academic (non-commercial) user, but the process requires a serial number. As bad luck would have it, the person who was the system administrator at the time the compiler was acquired is no longer with us. I asked some others involved with running the system if they might have the information, but to no avail, although one user suggested that support could be obtained in this forum, to which I noted that we had just gone full circle.

So is there any way to report this bug short of having somebody redownload and reinstall the compiler, making sure to save the serial number this time?

I'd be glad to report it on your behalf, but I can't reproduce the problem in the current compiler. Since 7.1 is now out, it would probably make sense for you to download 7.1 and get a new serial number.

Steve

Steve - Intel Developer Support

Leave a Comment

Please sign in to add a comment. Not a member? Join today