Redhat 8.0 support ?

Redhat 8.0 support ?

Will there be support for Redhat-8 and Suse-8.1?
What is the timeline?


6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I am currently using Redhat 8.0 with Intel Fortran.

my "ifc -V" gives:

Intel Fortran Compiler for 32-bit applications, Version 7.0 Build 20021028ZCopyright (C) 1985-2002 Intel Corporation. All rights reserved.

GNU ld version 20020802
Supported emulations:


It appears to have no problems with Redhat 8.

I would imagine that C++ could be trickier as the GNU gcc linkage standards for C++ changed fairly significantly to be more standards compliant..... but in the C++ world "standards compliant" too often means "will not work for three more years with anything else", in practice, quite the opposite of the intent.

What about debugger?

It does not work with SuSe 8.1.

Have you tried gdbf95?

Since I don't know what you mean by "doesn't work,"
I'll point out that certain applications written for redhat 7.[1-3] require the optional g++ compatibility libraries to run on newer installations.

Three main points:

Red Hat 8.0 contains a very new version of glibc, 2.2.93, (a preliminary version of glibc 2.3). The Intel Compiler 7.0 was designed to be compatible with the then-available glibc versions 2.2.4 and 2.2.5, as found in Red Hat 7.2 and 7.3. C++ applications compiled with the Intel C++ Compiler 7.0 are known to have incompatibilities with glibc 2.2.93. Fortran and some C applications may work with Red Hat 8.0, but this is not supported since it has not been tested. It is hoped to make available an updated version of the 7.0 compiler with support for Red Hat 8.0 in the first half of 2003.

SuSE 8.1 comes with glibc 2.2.5. Although the 7.0 compiler was not explicitly tested on SuSE 8.1, we would expect it to be usable, subject to the usual restrictions on mixing C++ binaries built with the Intel and gcc compilers, as described in the release notes.

There is a known issue with using the debugger, idb, in conjunction with the latest version of gcc, 3.2, which is available with SuSE 8.1 and other distributions. This will be fixed in a forthcoming patch for those who have support. idb works with older versions of gcc such as the 2.96 that comes with Red Hat 7.3.


I've been using ifc 7.0 and icc 7.0 on Redhat 8.0.
Works well so far. In fact I saw a speedup of
around 30% for my molecular dynamics applications
c.f. 6.0 (but ironically I see slowdown with -xW
and/or -tpp7). That was with ifc 7.0-76.

I havent had a chance to try mpich and my MPI
parallelised code yet; soon.

I've just installed ifc 7.0-84 and I'm finding that
idb now works. Great. Cant see mention of anything
specific in ifc_fixes.txt or ifc_issues.txt.

I had a look at gdbf95 (on Tim Prince's earlier
suggestion). It sort of worked (had a problem with
allocated arrays in modules which I use a lot). I read
through the gdb-patches maillist (,
cant reach it right at the moment to double check) but
it wasnt clear if the patches proposed for gdbf95 have
been accepted for gdb 5.4. gdbf95 website says Intel funded the work.



Leave a Comment

Please sign in to add a comment. Not a member? Join today