[bug report: 11.0.074] catastrophic error: **Internal compiler error: internal abort**

[bug report: 11.0.074] catastrophic error: **Internal compiler error: internal abort**

Hi!

I was trying to compile the Molpro Quantum Molecular program package,

http://www.molpro.net/

and I had the following error:

compiling geminal.f
failed
0_1871

: catastrophic error: **Internal compiler error: internal abort** Please report this error along with the circumstances in which it occurred in a Software Problem Report. Note: File and line given may not be explicit cause of this error.
in file geminal.f, line 2348, column 17

compilation aborted for geminal.f (code 3)
make[3]: *** [geminal.o] Error 1

In the geminal.f file (fortran 77 code) the line 2348 and the column 17 refers to a "enddo" (sixth line):

              do i=1,nt(1)
                do j=1,nt(1)
                  ij1=i+(j-1)*ntb(1)
                  ij2=i+(j-1)*nt(1)
                  q(is+ij2-1)=q(is_dummy+ij1-1)
                enddo
              enddo

I don't have this problem with ifort 10.1.012.

P.S.: I don't upload the geminal.f file due to copyrights restrictions.

15 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I will take another look at this on Monday. Initially, I assumed you were using the 32-bit compiler.

Retired 12/31/2016

I don't know if it is important, but my kernel is 2.6.27-10 (at ubuntu intrepid), and my processor is a core2duo p8400 (from a toshiba satellite).

I found (with some help!) that Molpro's CONFIG file puts -O3 as default to compile fortran sources.

FOPT=-O3

I tried to compile the geminal.f with -O2

ifort -O2 -c geminal.f (Sucess!)

ifort -O3 -c geminal.f (Catastrophic error!)

After this, I put the local/geminal.f at the -O2 "exception" list:

F_OPT2=sapt/integrals.f90 slater/RL4gen1.f local/geminal.f

Hey man! I have a parallel version of Molpro working now!

I expect that someone find why this error gets in 11.0 and not in 10.1.

I got the sources but can't reproduce the problem. Can you show me the exact command line being used to compile this source? Also, which platform are you compiling for (32 or 64-bit)?

Retired 12/31/2016

Quoting - Steve Lionel (Intel)

I got the sources but can't reproduce the problem. Can you show me the exact command line being used to compile this source? Also, which platform are you compiling for (32 or 64-bit)?

I compiled for 64bit in Ubuntu Intrepid.

$ which ifort
/usr/local/intel/Compiler/11.0/074/bin/intel64/ifort

When I started this thread, I was using kernel 2.6.27-10-generic.

$ ls /usr/src
linux-headers-2.6.27-10-generic
linux-headers-2.6.27-11-generic
linux-headers-2.6.27-7-generic
linux-headers-2.6.27-9-generic

The exact command line to get this bug (with the kernel 2.6.27-10-generic) was:

$ ifort -O3 -c geminal.f

I updated to kernel 2.6.27-11-generic, and I cannot reproduce the bug anymore!
Now the file compiles with -O3 with a ton of warnings (but the module is successfully created). Take a look at gemlog-2.6.27.11.txt file.

$ ls
common geminal.f geminal.mod geminal.o

I am very impressed with this result.
I think is related with the limits defined in the kernel headers... I don't know.

To make sure we are talking about the same sources, take a look in version-2008.1.txt file, where I put the head of geminal.f file and the list of common directory.

Happy Holidays!


Did you intend to attach some files to this post? You have to go back into Add Files, click on the folder, click on the file and then click Add as Attachment.

What warnings do you get?

Retired 12/31/2016

Quoting - Steve Lionel (Intel)

Did you intend to attach some files to this post? You have to go back into Add Files, click on the folder, click on the file and then click Add as Attachment.

What warnings do you get?

Ow crap! I thought that was sufficient to put into the folder!

Sorry!!

Attachments: 

Yes, I saw those warnings, but they go away if you build using the options specified in the configuration, which includes -autodouble.

Retired 12/31/2016

Quoting - Steve Lionel (Intel)

Yes, I saw those warnings, but they go away if you build using the options specified in the configuration, which includes -autodouble.

I put -autodouble, but I did not get any change. I still have exactly the same warnings (I compared with vimdiff).

I searched for -autodouble in "man ifort" but I didn't find it.
Note, I am using ifort 11.0.074 (Intel 64).

# which ifort
/usr/local/intel/Compiler/11.0/074/bin/intel64/ifort

But I found it in version 10.1.012.
Is there an equivalent option in ifort 11?

If it is helpful, I compiled with "-warn all" option, and I am uploading to this post (with and without -autodouble).

Attachments: 

Quoting - Steve Lionel (Intel)

Yes, I saw those warnings, but they go away if you build using the options specified in the configuration, which includes -autodouble.

Steve,

I thought about the CONFIG flags, and I tried to compile with them.

The default flags to FORTRAN are (created automatically by MOLPRO configure file):

-i8 -fPIC -pc 64 -auto -autodouble -Vaxlib -vec-report0

When I try these, with additionally -O3 flag, I get the following result.

# ifort -O3 -i8 -fPIC -pc 64 -auto -autodouble -Vaxlib -vec-report0 -c geminal.f
0_1871

: catastrophic error: **Internal compiler error: internal abort** Please report this error along with the circumstances in which it occurred in a Software Problem Report. Note: File and line given may not be explicit cause of this error.
in file geminal.f, line 2348, column 17

compilation aborted for geminal.f (code 3)

The bug comes back with these flags!!

I removed one by one, and without the -i8 flag, the file compile with those warnings (gemlog-without-i8.txt file).

I think it may be useful, so I compiled the file with "-warn all -i8" plus -O2 and -O3 (gemlog-warn-all-i8-O2.txt and gemlog-warn-all-i8-O3.txt files).

They are almost the same, with a few differences, and the most import of course is that -O2 compiles, and -O3 does not compile.

Are you sure our file versions are the same?

Attachments: 

Quoting - Steve Lionel (Intel)

I will take another look at this on Monday. Initially, I assumed you were using the 32-bit compiler.

Ok!

I expect to help to improve the Intel Compiler. If you need other data or tests, just ask.

Happy new year!

I can reproduce this error and have created a cut-down test case which I submitted to development. The issue ID is DPD200111251. Curiously, the cut-down test case does not need -i8 for correctness but -i8 along with -O3 is required to trigger the error. No other switches are needed to show it. Thanks for bringing this to our attention.

Retired 12/31/2016

Quoting - Steve Lionel (Intel)

I can reproduce this error and have created a cut-down test case which I submitted to development. The issue ID is DPD200111251. Curiously, the cut-down test case does not need -i8 for correctness but -i8 along with -O3 is required to trigger the error. No other switches are needed to show it. Thanks for bringing this to our attention.

I feel happy to contribute.

But isn't this error triggered just with -O3 (without -i8) when using kernel 2.6.27.10-generic? These are my first posts.


Best Reply

I don't think the kernel version is relevant. I can reproduce the error on Windows too. I needed both switches to see the error. Note that -autodouble implies -i8.

Retired 12/31/2016

Leave a Comment

Please sign in to add a comment. Not a member? Join today