l_cprof_p_11.0.074_intel64 and missing libstdc++.so.5

l_cprof_p_11.0.074_intel64 and missing libstdc++.so.5

Dear all,
trying to install l_cprof_p_11.0.074_intel64 on an x86_64 linux
system I have the same problem reported in

http://software.intel.com/en-us/forums/showthread.php?t=62126

I see the following message in the installer:

Step no: 4 of 7 | Installation configuration - Missing Critical Pre-requisite
--------------------------------------------------------------------------------
The following required for installation commands are missing:
libstdc++.so.5 (library)

however I think that I have libstdc++.so.5:

locate libstdc++.so.5
/usr/lib64/libstdc++-v3/libstdc++.so.5
/usr/lib64/libstdc++-v3/libstdc++.so.5.0.7
/usr/lib32/libstdc++-v3/libstdc++.so.5.0.7
/usr/lib32/libstdc++-v3/libstdc++.so.5
[...]/l_cprof_p_11.0.074_intel64/pset/32/gcc-3.2/libstdc++.so.5
[...]/l_cprof_p_11.0.074_intel64/pset/64/gcc-3.2/libstdc++.so.5
[...]/l_cprof_p_11.0.074_intel64/pset/32e/gcc-3.2/libstdc++.so.5

My system:

uname -a
Linux 2.6.23-gentoo-r6 x86_64
AMD Turion 64 Mobile Technology ML-32 AuthenticAMD GNU/Linux

How could I fix this? Thank you!
Marco Restelli

26 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Is g++ working (as root, if doing a root install)? Normally, 'g++ -print-search-dirs' would be used to find such things. I suppose the last one, provided by the ifort installer, could be used only if a gcc-3.2 installation were active. It would be better to have a more recent gcc, to provide components required by ifort.
I recall some problems about the original Turion not supporting SSE2; I assume, as you are running x86_64, you don't have that problem.

Quoting - tim18
Is g++ working (as root, if doing a root install)? Normally, 'g++ -print-search-dirs' would be used to find such things. I suppose the last one, provided by the ifort installer, could be used only if a gcc-3.2 installation were active. It would be better to have a more recent gcc, to provide components required by ifort.
I recall some problems about the original Turion not supporting SSE2; I assume, as you are running x86_64, you don't have that problem.

tim18,
thank you for the reply. Yes, I am running x86_64. I am doing the
user install:

3. Install as current user to limit access to user level

Anyway, I have g++ 4.1.2, and from g++ -print-search-dirs I see, among
other things, /usr/lib64, which is where I have
libstdc++-v3/libstdc++.so.5. I can even compile an empty main linking
the library:

gcc xxx.cpp -lstdc++ -o xxx

However, g++ -print-search-dirs does not show the /usr/lib32 folder,
which is probably what the installer is looking for. Here, I am not
sure how to proceed. Should g++ also be aware of the lib32 folder? Is
there any log produced by the installer, where one can find how it
detected the problem?

Thank you,
Marco Restelli

The 11.0 Intel64 compiler is a native compiler, and would not require the 32-bit g++ libraries, as the 10.1 compiler did.
If you had the 32-bit g++ installed, 'g++ -m32 -print-search-dirs' should show where those libraries are, but you would need them only if you install the ia32 ifort, or the 10.1.
There may be an installation logging option, but I haven't seen it documented. It may be buried in one of the install scripts, possibly down in an intel64 directory.
If you reach a dead end on this forum, you could submit a request for installation help on premier.intel.com, after you register your serial number at https://registrationcenter.intel.com.

I also encount this problem. but the system i used is a bit different.
uname -a
Linux zsq-laptop 2.6.27-9-generic #1 SMP Thu Nov 20 21:57:00 UTC 2008 i686 GNU/Linux

finally fixed the problem. the solution is:
I downloaded the file of 'libstdc++.so.5' and ' libstdc++.so.5.0.3' , and then copy them to the directory of' /usr/lib/'
so you can have a try

Placing 64-bit .so in /usr/lib/ is a debian/ubuntu quirk which is contrary to the standards adhered to by other distros, which reserve such directories for 32-bit, and use /usr/lib64 for 64-bit. gcc has to be built with a special option for debian or ubuntu. I didn't think gentoo was one of the odd ones, maybe the ifort installer doesn't know this. This is one reason for checking 'g++ -print-search-dirs' (to verify whether your g++ is using astandard directory structure, or a different one).

Quoting - tim18
Placing 64-bit .so in /usr/lib/ is a debian/ubuntu quirk which is contrary to the standards adhered to by other distros, which reserve such directories for 32-bit, and use /usr/lib64 for 64-bit. gcc has to be built with a special option for debian or ubuntu. I didn't think gentoo was one of the odd ones, maybe the ifort installer doesn't know this. This is one reason for checking 'g++ -print-search-dirs' (to verify whether your g++ is using astandard directory structure, or a different one).

Thank you for the replies. Indeed, g++ -m32 -print-search-dirs finds
the /usr/lib32 folder. Moreover, on my system /usr/lib is a symbolic
link to /usr/lib64, so that one can say that the 64-bit .so are in
/usr/lib/

As for the installer, the messages are as follows:

Step no: 4 of 7 | Installation configuration - Missing Critical
Pre-requisite

Missing critical pre-requisite
-- missing system commands
-- 32-bit libraries not found

and then

The following required for installation commands are missing:
libstdc++.so.5 (library)

and finally

32-bit libraries not found on this system.
This product release requires the presence of 32-bit compatibility
libraries when running on Intel 64 architecture systems. One or
more of these libraries could not be found:
libstdc++
libstdc++5
glibc
libgcc
Without these libraries, the compiler will not function properly.
These libraries, if not installed, can be installed from the OS discs
after finishing the compiler installation. Please refer to Release
Notes for more information.

From this message, I was assuming that the problem was with the 32-bit
version of libstdc++5. Notice that I do have the library in /usr/lib
(the 64-bit) and /usr/lib32 (the 32-bit) already. Also, I don't see
any option to proceed with the compiler installation despite the
missing library.

I will try the premier.intel.com. Thank you all,
Marco Restelli

Something is wrong, ifthe 11.0 Intel64 64-bit compiler(notthe ia32 one) is looking for 32-bit libraries, as appears to be the case. However, if the installer doesn't recognize your installation as debian/ubuntu style, it would be expecting 32-bit libraries in /usr/lib and the like.
"missing system commands" is bad news; I've never seen that.

Quoting - tim18

Something is wrong, ifthe 11.0 Intel64 64-bit compiler(notthe ia32 one) is looking for 32-bit libraries, as appears to be the case. However, if the installer doesn't recognize your installation as debian/ubuntu style, it would be expecting 32-bit libraries in /usr/lib and the like.
"missing system commands" is bad news; I've never seen that.

Hi people,

Has anybody been able to resolve this installation issue yet ?

I am running Fedora 10 64bit on a core2duo and am having the same problem where 32bit libaries are missing and called for.

locate libstdc++.so
/usr/lib/gcc/x86_64-redhat-linux/4.3.2/libstdc++.so
/usr/lib/gcc/x86_64-redhat-linux/4.3.2/32/libstdc++.so
/usr/lib64/libstdc++.so.6
/usr/lib64/libstdc++.so.6.0.10

g++ -print-search-dirs results in this.
install: /usr/lib/gcc/x86_64-redhat-linux/4.3.2/
programs: =/usr/libexec/gcc/x86_64-redhat-linux/4.3.2/:/usr/libexec/gcc/x86_64-redhat-linux/4.3.2/:/usr/libexec/gcc/x86_64-redhat-linux/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/:/usr/lib/gcc/x86_64-redhat-linux/:/usr/libexec/gcc/x86_64-redhat-linux/4.3.2/:/usr/libexec/gcc/x86_64-redhat-linux/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/:/usr/lib/gcc/x86_64-redhat-linux/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../../x86_64-redhat-linux/bin/x86_64-redhat-linux/4.3.2/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../../x86_64-redhat-linux/bin/
libraries: =/usr/lib/gcc/x86_64-redhat-linux/4.3.2/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../../x86_64-redhat-linux/lib/x86_64-redhat-linux/4.3.2/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../../x86_64-redhat-linux/lib/../lib64/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../x86_64-redhat-linux/4.3.2/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../../lib64/:/lib/x86_64-redhat-linux/4.3.2/:/lib/../lib64/:/usr/lib/x86_64-redhat-linux/4.3.2/:/usr/lib/../lib64/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../../x86_64-redhat-linux/lib/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../:/lib/:/usr/lib/

regards

Quoting - drdos2006

Hi people,

Has anybody been able to resolve this installation issue yet ?

I am running Fedora 10 64bit on a core2duo and am having the same problem where 32bit libaries are missing and called for.

locate libstdc++.so
/usr/lib/gcc/x86_64-redhat-linux/4.3.2/libstdc++.so
/usr/lib/gcc/x86_64-redhat-linux/4.3.2/32/libstdc++.so
/usr/lib64/libstdc++.so.6
/usr/lib64/libstdc++.so.6.0.10

g++ -print-search-dirs results in this.
install: /usr/lib/gcc/x86_64-redhat-linux/4.3.2/
programs: =/usr/libexec/gcc/x86_64-redhat-linux/4.3.2/:/usr/libexec/gcc/x86_64-redhat-linux/4.3.2/:/usr/libexec/gcc/x86_64-redhat-linux/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/:/usr/lib/gcc/x86_64-redhat-linux/:/usr/libexec/gcc/x86_64-redhat-linux/4.3.2/:/usr/libexec/gcc/x86_64-redhat-linux/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/:/usr/lib/gcc/x86_64-redhat-linux/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../../x86_64-redhat-linux/bin/x86_64-redhat-linux/4.3.2/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../../x86_64-redhat-linux/bin/
libraries: =/usr/lib/gcc/x86_64-redhat-linux/4.3.2/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../../x86_64-redhat-linux/lib/x86_64-redhat-linux/4.3.2/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../../x86_64-redhat-linux/lib/../lib64/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../x86_64-redhat-linux/4.3.2/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../../lib64/:/lib/x86_64-redhat-linux/4.3.2/:/lib/../lib64/:/usr/lib/x86_64-redhat-linux/4.3.2/:/usr/lib/../lib64/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../../x86_64-redhat-linux/lib/:/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../:/lib/:/usr/lib/

regards

Fedora is quite easy - you need to add rpm package compat-libstdc++. Here is my FC9 system (10 should be similiar)

rpm -qa | grep compat-libstdc++
$ rpm -qa | grep compat-libstdc++
compat-libstdc++-33-3.2.3-63.x86_64
compat-libstdc++-33-3.2.3-63.i386

$ rpm -ql compat-libstdc++-33-3.2.3-63.i386
/usr/lib/libstdc++.so.5
/usr/lib/libstdc++.so.5.0.7

Note that there is a x86_64 and an i386 version of compat-libstdc++.

For the other distros, you will need to find the equivalent libs for 32 and 64 bit.

Marco,

The additional subdirectory that Gentoo puts on the libs, libstdc++-v3/, is unusual. I am checking with our install team, but I doubt that subdir(s) will be searched. Try this:

ln -s /usr/lib64/libstdc++v3/libstdc++.so.5 /usr/lib64/libstdc++.so.5
ln -s /usr/lib32/libstdc++v3/libstdc++.so.5 /usr/lib32/libstdc++.so.5

This to create symbolic links in /usr/lib32 and /user/lib64 to libstdc++.so.5 files directly.

Please let us know if this works. I wonder if other distros have this odd subdir path, it is the first I've seen it.

ron

Quoting - Ronald Green (Intel)
Marco,

The additional subdirectory that Gentoo puts on the libs, libstdc++-v3/, is unusual. I am checking with our install team, but I doubt that subdir(s) will be searched. Try this:

ln -s /usr/lib64/libstdc++v3/libstdc++.so.5 /usr/lib64/libstdc++.so.5
ln -s /usr/lib32/libstdc++v3/libstdc++.so.5 /usr/lib32/libstdc++.so.5

This to create symbolic links in /usr/lib32 and /user/lib64 to libstdc++.so.5 files directly.

Please let us know if this works. I wonder if other distros have this odd subdir path, it is the first I've seen it.

ron

Ron,
thank you for your suggestion. Unfortunately, it does not work yet,
and I get exactly the same error messages. After double checking this
thread and the replies that I have got on the Intel support, however,
I think am still confused about (at least) two points:

1) does l_cprof_p_11.0.074_intel64 need the 32bit libstdc++.so.5 ?

2) the install script seems to me a shell script; please could you
point me to the part of the script which checks the prerequisites? My
hope is that, once I know what the script is looking for and how, I
would have better odds to make it find it, maybe with symbolic links.
Otherwise I have the feeling that all the suggestions are kind of
shooting in the dark...

Thank you!
Marco

Quoting - mrestelli@gmail.com

Ron,
thank you for your suggestion. Unfortunately, it does not work yet,
and I get exactly the same error messages. After double checking this
thread and the replies that I have got on the Intel support, however,
I think am still confused about (at least) two points:

1) does l_cprof_p_11.0.074_intel64 need the 32bit libstdc++.so.5 ?

2) the install script seems to me a shell script; please could you
point me to the part of the script which checks the prerequisites? My
hope is that, once I know what the script is looking for and how, I
would have better odds to make it find it, maybe with symbolic links.
Otherwise I have the feeling that all the suggestions are kind of
shooting in the dark...

Thank you!
Marco

The key part that will help us is the results of these 2 command:

/sbin/ldconfig -p | grep libstdc++.so.5
uname -a

from these 2 results we should be able to figure out what is going on.

We don't officially support Gentoo, so I don't have a sandbox to test this on. Do give me the results of the 2 commands above.

Quoting - Ronald Green (Intel)

The key part that will help us is the results of these 2 command:

/sbin/ldconfig -p | grep libstdc++.so.5
uname -a

from these 2 results we should be able to figure out what is going on.

We don't officially support Gentoo, so I don't have a sandbox to test this on. Do give me the results of the 2 commands above.

A few more debug tips:

export LOCAL_INSTALL_VERBOSE=1
script /tmp/my_install.log
./install.sh
...output ...
exit

after the 'exit', attach the output in /tmp/my_install.log

Quoting - Ronald Green (Intel)

after the 'exit', attach the output in /tmp/my_install.log

A few more debug tips:

export LOCAL_INSTALL_VERBOSE=1
script /tmp/my_install.log
./install.sh
...output ...
exit

Ronald,
here we go:

/sbin/ldconfig -p | grep libstdc++.so.5
libstdc++.so.5 (libc6,x86-64) => /usr/lib64/libstdc++-v3/libstdc++.so.5
libstdc++.so.5 (libc6) => /usr/lib32/libstdc++-v3/libstdc++.so.5

uname -a
Linux xxx 2.6.23-gentoo-r6 #1 SMP Thu Feb 7 21:54:51 CET 2008 x86_64
AMD Turion 64 Mobile Technology ML-32 AuthenticAMD GNU/Linux

The output of the install script is attached. Thank you,
Marco

Attachments: 

AttachmentSize
Downloadapplication/octet-stream my_install.log32.17 KB

I don't see much more help in the log. Is the 32-bit libstdc++ on one of the paths displayed by 'g++ -m32 -print-search-dirs' ?
A standard LSB installation wouldn't require searching libraries such as /usr/lib32, as 32-bit libraries would appear in /usr/lib. If you could persuade the installer to think like Ubuntu, you might get past this.

Marco,

There should also be another log left in:

/tmp/intel.pset..xxxxx.log

Could you send that also? This will certainly help future Gentoo users once we get this resolved.

Quoting - Ronald Green (Intel)
Marco,

There should also be another log left in:

/tmp/intel.pset..xxxxx.log

Could you send that also? This will certainly help future Gentoo users once we get this resolved.

Tim, Ronald,
the 32-bit libstdc++ is in the search path of g++ up to
/usr/lib32/, the additional folder /usr/lib32/libstdc++-v3/ does not
appear in g++ -m32 -print-search-dirs. Notice however that this is
exactly the case also for the 64-bit library, which I can link without
explicitly specifying the libstdc++-v3 folder. Moreover, including a
symbolic link to the library directly in /usr/lib32 as suggested in a
previous post does not help the Intel installer.

The additional log file is attached. Thank you for you attention, I
hope this can be helpful for other (potential) users too!

Marco

Quoting - mrestelli@gmail.com

Tim, Ronald,
the 32-bit libstdc++ is in the search path of g++ up to
/usr/lib32/, the additional folder /usr/lib32/libstdc++-v3/ does not
appear in g++ -m32 -print-search-dirs. Notice however that this is
exactly the case also for the 64-bit library, which I can link without
explicitly specifying the libstdc++-v3 folder. Moreover, including a
symbolic link to the library directly in /usr/lib32 as suggested in a
previous post does not help the Intel installer.

The additional log file is attached. Thank you for you attention, I
hope this can be helpful for other (potential) users too!

Marco

Sorry, the file was missing.

Attachments: 

Quoting - mrestelli@gmail.com
Thank you for the replies. Indeed, g++ -m32 -print-search-dirs finds
the /usr/lib32 folder. Moreover, on my system /usr/lib is a symbolic
link to /usr/lib64, so that one can say that the 64-bit .so are in
/usr/lib/

As for the installer, the messages are as follows:

Step no: 4 of 7 | Installation configuration - Missing Critical
Pre-requisite

Missing critical pre-requisite
-- missing system commands
-- 32-bit libraries not found

and then

The following required for installation commands are missing:
libstdc++.so.5 (library)

and finally

32-bit libraries not found on this system.
This product release requires the presence of 32-bit compatibility
libraries when running on Intel 64 architecture systems. One or
more of these libraries could not be found:
libstdc++
libstdc++5
glibc
libgcc
Without these libraries, the compiler will not function properly.
These libraries, if not installed, can be installed from the OS discs
after finishing the compiler installation. Please refer to Release
Notes for more information.

From this message, I was assuming that the problem was with the 32-bit
version of libstdc++5. Notice that I do have the library in /usr/lib
(the 64-bit) and /usr/lib32 (the 32-bit) already. Also, I don't see
any option to proceed with the compiler installation despite the
missing library.

I will try the premier.intel.com. Thank you all,
Marco Restelli

I have the very exact same problem with the intel c compiler on my gentoo amd64, and after I get that installed, I will have to install fortran as well.

If anyone has ideas, please let us know. Here's some libstdc++ info.

# ldconfig -p | grep libstdc++
libstdc++.so.6 (libc6,x86-64) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/libstdc++.so.6
libstdc++.so.6 (libc6) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/32/libstdc++.so.6
libstdc++.so.5 (libc6,x86-64) => /usr/lib64/libstdc++-v3/libstdc++.so.5
libstdc++.so.5 (libc6) => /usr/lib32/libstdc++-v3/libstdc++.so.5
libstdc++.so.2.9 (libc6) => /usr/lib32/libstdc++.so.2.9
libstdc++.so.2.8 (libc6) => /usr/lib32/libstdc++.so.2.8
libstdc++.so.2.7.2 (libc6) => /usr/lib32/libstdc++.so.2.7.2
libstdc++.so (libc6,x86-64) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/libstdc++.so
libstdc++.so (libc6) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/32/libstdc++.so
libstdc++-libc6.2-2.so.3 (libc6) => /usr/lib32/libstdc++-libc6.2-2.so.3
libstdc++-libc6.1-1.so.2 (libc6) => /usr/lib32/libstdc++-libc6.1-1.so.2

# ldconfig -p | grep libstdc++.so.5
libstdc++.so.5 (libc6,x86-64) => /usr/lib64/libstdc++-v3/libstdc++.so.5
libstdc++.so.5 (libc6) => /usr/lib32/libstdc++-v3/libstdc++.so.5

# uname -m
x86_64

# g++ -m32 -print-search-dirs
install: /usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/
programs: =/usr/libexec/gcc/x86_64-pc-linux-gnu/4.1.2/:/usr/libexec/gcc/x86_64-pc-linux-gnu/4.1.2/:/usr/libexec/gcc/x86_64-pc-linux-gnu/:/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/:/usr/lib/gcc/x86_64-pc-linux-gnu/:/usr/libexec/gcc/x86_64-pc-linux-gnu/4.1.2/:/usr/libexec/gcc/x86_64-pc-linux-gnu/:/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/:/usr/lib/gcc/x86_64-pc-linux-gnu/:/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../x86_64-pc-linux-gnu/bin/x86_64-pc-linux-gnu/4.1.2/:/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../x86_64-pc-linux-gnu/bin/
libraries: =/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/32/:/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/32/:/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../x86_64-pc-linux-gnu/lib/x86_64-pc-linux-gnu/4.1.2/32/:/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../x86_64-pc-linux-gnu/lib/../lib32/:/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../x86_64-pc-linux-gnu/4.1.2/32/:/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../lib32/:/lib/x86_64-pc-linux-gnu/4.1.2/32/:/lib/../lib32/:/usr/lib/x86_64-pc-linux-gnu/4.1.2/32/:/usr/lib/../lib32/:/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/:/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/:/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../x86_64-pc-linux-gnu/lib/x86_64-pc-linux-gnu/4.1.2/:/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../x86_64-pc-linux-gnu/lib/:/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../x86_64-pc-linux-gnu/4.1.2/:/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../:/lib/x86_64-pc-linux-gnu/4.1.2/:/lib/:/usr/lib/x86_64-pc-linux-gnu/4.1.2/:/usr/lib/

And something I just found. There are ebuilds for gentoo that provide the Intel Fortran Compiler as well as the C compiler (ifc/icc). So, what's the difference with those compilers which don't cost a thing, and the compilers we bought from Intel (other than it seems to be a version behind).

I have just posted the Linux silent installation procedure here:

http://software.intel.com/en-us/forums/showthread.php?t=63038

Try this procedure. I assume that slamd64 is Debian based and thus does not have RPM. For this case, modify the invocation of install_fc.sh thusly:

install_fc.sh -n --run --silent FILENAME

using the -n to get a non-rpm install.

For the FILENAME configuration file (copied from SilentInstallConfigFile.ini) you'll want something like this:

# IA32

[ifort11-ia32]
INSTALLDIR=/opt/intel/Compiler/11.0/074
OPTIONS=-U --replacefiles --force --nodeps
EULA=accept
ECL_DISCLAIMER=accept
NON_SUPPORTED_OS_INSTALL=Yes
REPLACE_EXISTING_INSTALLATION=Yes

[iidb11-ia32]
INSTALLDIR=/opt/intel/Compiler/11.0/074
OPTIONS=-U --replacefiles --force --nodeps
EULA=accept
NON_SUPPORTED_OS_INSTALL=Yes
REPLACE_EXISTING_INSTALLATION=Yes

[mkl11-ia32]
INSTALLDIR=/opt/intel/Compiler/11.0/074
OPTIONS=-U --replacefiles --force --nodeps
EULA=accept
NON_SUPPORTED_OS_INSTALL=Yes
REPLACE_EXISTING_INSTALLATION=Yes

and similarly for the configs for Intel 64.

Keep in mind, this does not guarantee your compiler will work after installation. You are using a non-supported Linux distribution. We are bypassing the prerequisite checks so all bets are off as to whether this will work or not.

ron

Quoting - Ronald Green (Intel)

I have just posted the Linux silent installation procedure here:

http://software.intel.com/en-us/forums/showthread.php?t=63038

Try this procedure. I assume that slamd64 is Debian based and thus does not have RPM. For this case, modify the invocation of install_fc.sh thusly:

install_fc.sh -n --run --silent FILENAME

using the -n to get a non-rpm install.

[...]

ron

Ron, now it works! I had some troubles with -n, which seemed to be
ignored, so I installed rpm (app-arch/rpm in gentoo terminology) and I
had to run the script as root even if I was installing into a local
folder. Anyway, it works now (and a quick test shows even a speed up
of ~7% compared to ifort 10.1).

Thank you,
Marco

Hi forks,

As specified in the release notes, Intel Fortran 11.0 for Intel64 (x86-64) architecture does require 32-bit libraries.

I installed them on my Ubuntu 8.10 as follows:

1. Run "Synaptic Package Manager"
2. Check ia32-libs and libstdc++5. (Use quick search text box!)
3. Click Apply.

Regards,

Byung

Quoting - Ronald W. Green (Intel)

I have just posted the Linux silent installation procedure here:

http://software.intel.com/en-us/forums/showthread.php?t=63038

Try this procedure. I assume that slamd64 is Debian based and thus does not have RPM. For this case, modify the invocation of install_fc.sh thusly:

install_fc.sh -n --run --silent FILENAME

using the -n to get a non-rpm install.

For the FILENAME configuration file (copied from SilentInstallConfigFile.ini) you'll want something like this:

# IA32

[ifort11-ia32]
INSTALLDIR=/opt/intel/Compiler/11.0/074
OPTIONS=-U --replacefiles --force --nodeps
EULA=accept
ECL_DISCLAIMER=accept
NON_SUPPORTED_OS_INSTALL=Yes
REPLACE_EXISTING_INSTALLATION=Yes

[iidb11-ia32]
INSTALLDIR=/opt/intel/Compiler/11.0/074
OPTIONS=-U --replacefiles --force --nodeps
EULA=accept
NON_SUPPORTED_OS_INSTALL=Yes
REPLACE_EXISTING_INSTALLATION=Yes

[mkl11-ia32]
INSTALLDIR=/opt/intel/Compiler/11.0/074
OPTIONS=-U --replacefiles --force --nodeps
EULA=accept
NON_SUPPORTED_OS_INSTALL=Yes
REPLACE_EXISTING_INSTALLATION=Yes

and similarly for the configs for Intel 64.

Keep in mind, this does not guarantee your compiler will work after installation. You are using a non-supported Linux distribution. We are bypassing the prerequisite checks so all bets are off as to whether this will work or not.

ron

Is there another page with the silent installation procedure (the link above gave me a 404 error)? I'm using gentoo on amd64 and would love to upgrade from 10.1.

Retired 12/31/2016

Thanks Steve, worked beautifully so far as I can tell.

Leave a Comment

Please sign in to add a comment. Not a member? Join today