Cannot install on Ubuntu 9.10

Cannot install on Ubuntu 9.10

Hello

Somehow I cannot install the fortran compiler 11.1 on Ubuntu 9.10, I get:

ERROR: Incorrect directory name. Directory name can contain only [a-z], [A-Z], [0-9], "-", "_" and "." symbols.
Note: Press "Enter" key to back to the previous menu.
Please type the full path to the installation directory starting with "/" :

...and whatever installation path I insert, it still gives the error message and I have no idea what is wrong.

Does anybody have a glue? Ubuntu is fresh install.

16 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Make certain there are no blank (or space) characters in the path you provided.

For example, the space after "intel" would trigger this message: /opt/intel compiler/

There is no space or special characters in the path and I have tried even the root folder, still the same error message. I do not understand it.

are you installing as root user?

is your linux using the English character set? non-english directory names are not supported.

Have you tried to install and use the default installation path of /opt/intel/Compiler ? If not, what EXACTLY are you giving it for a path (cut and paste so we can see your directory path)

and you have read the note on Ubuntu installation, right:

http://software.intel.com/en-us/articles/using-intel-compilers-for-linux-with-ubuntu/

Hi
I can confirm that this problem still exists in Ubuntu 11.10.
I have tryed to install with sudo and as regular user.
My linux is using utf8, command locale gives following output:

andres@al6420:~$ locale
LANG=et_EE.UTF-8
LANGUAGE=
LC_CTYPE="et_EE.UTF-8"
LC_NUMERIC="et_EE.UTF-8"
LC_TIME="et_EE.UTF-8"
LC_COLLATE="et_EE.UTF-8"
LC_MONETARY="et_EE.UTF-8"
LC_MESSAGES="et_EE.UTF-8"
LC_PAPER="et_EE.UTF-8"
LC_NAME="et_EE.UTF-8"
LC_ADDRESS="et_EE.UTF-8"
LC_TELEPHONE="et_EE.UTF-8"
LC_MEASUREMENT="et_EE.UTF-8"
LC_IDENTIFICATION="et_EE.UTF-8"
LC_ALL=

directory names are english
I have tried the default path and custom path.
I have also tried silent install with following configuration file, which ends with same error:
ACTIVATION=exist_lic
CONTINUE_WITH_INSTALLDIR_OVERWRITE=yes
CONTINUE_WITH_OPTIONAL_ERROR=yes
PSET_INSTALL_DIR=/home/andres/intel
INSTALL_MODE=RPM
ACCEPT_EULA=accept

My version of compiler is l_fcompxe_intel64_2011.7.256.tgz and ubuntu is 64bit as well.

Error from silent install command:

andres@al6420:l_fcompxe_intel64_2011.7.256$ sudo ./install.sh --silent ./my_silent_config.ini
ERROR: Incorrect directory name. Directory name can contain only [a-z], [A-Z], [0-9], "-", "_" and "." symbols.
--------------------------------------------------------------------------------
The provided Install Location is incorrect. Please correct the PSET_INSTALL_DIR
variable in silent configuration file.
--------------------------------------------------------------------------------

Best regards,
Andres

If you install as a "regular user," you have to choose an install path where you have write permission. I think I recall difficulty myself that I couldn't install by a single sudo command or by accepting the offer of the 11.1 install script to try to get root privilege. Did you try
sudo su -
as a separate step to gain root privilege before starting the install?
You will need to follow steps in the article above the forum about Ubuntu installation.
Using a current version of the compiler would save you from special steps required on Ubuntu.

Thank You TimP,
it is always good to remind the basics like write permissions, but this is not the issue at the moment. When I tried as a regular user, then the installation path was in my home folder and now I also tried with "sudo su -" and no difference at all. Besides, if it were a problem with write permissions, installer should mention it and not doing so is a problem in itself.

When trying silent install, the error is:
ERROR: Incorrect directory name. Directory name can contain only [a-z], [A-Z], [0-9], "-", "_" and "." symbols.
--------------------------------------------------------------------------------
The provided Install Location is incorrect. Please correct the PSET_INSTALL_DIR
variable in silent configuration file.

and the variable it complains about in configuration file is:
PSET_INSTALL_DIR=/home/andres/intel

Best regards,
Andres

Andres,I'm very confused by what you are doing. What is your goal: is it to install the compiler OR to install using silent install? Does it matter to you which method you use? I think the sudo is confusing the matter since it appears you want to install in your home directory.I would recommend removing the ~/intel directory and start again. Also, log file are stored in /tmp with names *.pset.*.log and *.issa.*.log. Remove those old log files too.If you use install.sh directly, as a user - FORGET sudo - what happens? You have options to install as current user, you have the option to change install directory and packages. If you do this, what errors do you see, if any?ron

Hi Ronald,
My goal is to have working installation of compiler and installation method really does not matter. I have tried interactive and silent install, as a regular user, with sudo and as root. I have tried the default location and home folder. The error message is always the same:

ERROR: Incorrect directory name. Directory name can contain only [a-z], [A-Z], [0-9], "-", "_" and "." symbols.
Note: Press "Enter" key to back to the previous menu.
Please type the full path to the installation directory starting with "/" : /home/andres/intel
ERROR: Incorrect directory name. Directory name can contain only [a-z], [A-Z], [0-9], "-", "_" and "." symbols.
Please type the full path to the installation directory starting with "/" :

I tried silent install to be able to double check the directory name, I cannot see anything wrong with it.

Best regards,
Andres

Go to /tmp and find the last 2 log files, *.issa.*.log and *.pset.*.log and attach those.

ron

The second log file indicates that an installation script passed a concatenated string to a script function:

'/home/andres/intel/composer_xe_2011_sp1.7.256, spece = 1405'

where two strings were expected:

'/home/andres/intel/composer_xe_2011_sp1.7.256', 'spece = 1405'

I note that 'spece' was probably intended to be 'space', since the installer calculated the space required as 1405M.

The '=' in the malformed path is what is seen as a disallowed character in a path string.

Thank mecej4,
but this concatenation is not something I have control over, I guess? It is done in install.32e or somewhere?

Andres

The log file is no longer visible as a message attachment, so I cannot help.

As I said earlier, there may be an error in the installation script or the script has become corrupted somehow.

I don't have an Ubuntu 9.04 system around any more. I tried with 11.04 without problems.

I set LANG=et_EE.UTF-8
I installed as a standard user, NO sudo
I installed as root

Do not use silent installation. Do not use sudo. Install as root to the default directory OR install as a normal user to your home directory.

If you want to install as root,
sudo su -
to get a root shell.

Use the interactive installation.

Check your prerequisites are installed:
apt-get install apt-show-versions

# apt-show-versions | grep -i essen
build-essential/natty uptodate 11.5ubuntu1

# apt-show-versions | grep gcc-multilib
gcc-multilib/natty uptodate 4:4.5.2-1ubuntu3

apt-show-versions | grep rpm
librpm1/natty uptodate 4.8.1-6ubuntu1
librpmbuild1/natty uptodate 4.8.1-6ubuntu1
librpmio1/natty uptodate 4.8.1-6ubuntu1
rpm/natty uptodate 4.8.1-6ubuntu1
rpm-common/natty uptodate 4.8.1-6ubuntu1
rpm2cpio/natty uptodate 4.8.1-6ubuntu1

# apt-show-versions | grep ia32-libs
ia32-libs/natty uptodate 20090808ubuntu13

# java -version
java version "1.6.0_22"
OpenJDK Runtime Environment (IcedTea6 1.10.2) (6b22-1.10.2-0ubuntu1~11.04.1)
OpenJDK 64-Bit Server VM (build 20.0-b11, mixed mode)

mecej4:
Interesting, I can click on attachments in my post and open them.

Ronald W. Green:
I'm using Ubuntu 11.10, which is not officially supported?! Sorry about the confusion, as problem was the same, I did not start new thread.

So, with 11.10 it says me at the very beginning:

Missing optional pre-requisites
-- unsupported OS

About other prerequisites:
andres@al6420:~$ apt-show-versions |grep -i essen
build-essential/oneiric uptodate 11.5ubuntu1

andres@al6420:~$ apt-show-versions | grep gcc-multilib
gcc-multilib/oneiric uptodate 4:4.6.1-2ubuntu5

andres@al6420:~$ apt-show-versions | grep rpm
librpm2/oneiric uptodate 4.9.0-7
librpmbuild2/oneiric uptodate 4.9.0-7
librpmio2/oneiric uptodate 4.9.0-7
librpmsign0/oneiric uptodate 4.9.0-7
python-renderpm/oneiric uptodate 2.5-1.1
rpm/oneiric uptodate 4.9.0-7
rpm-common/oneiric uptodate 4.9.0-7
rpm2cpio/oneiric uptodate 4.9.0-7

andandres@al6420:~$ java -version
java version "1.6.0_23"
OpenJDK Runtime Environment (IcedTea6 1.11pre) (6b23~pre10-0ubuntu5)
OpenJDK 64-Bit Server VM (build 20.0-b11, mixed mode)

res@al6420:~$ apt-show-versions | grep ia32-libs
ia32-libs/oneiric uptodate 20090808ubuntu26
ia32-libs-multiarch 20090808ubuntu26 installed: No available version in archive

andres@al6420:~$ java -version
java version "1.6.0_23"
OpenJDK Runtime Environment (IcedTea6 1.11pre) (6b23~pre10-0ubuntu5)
OpenJDK 64-Bit Server VM (build 20.0-b11, mixed mode)

So all packages are somewhat newer but should be available.

mecej4:
Interesting, I can click on attachments in my post and open them.

I cannot even see the links. Please check whether you marked them "private" while editing your post.

Leave a Comment

Please sign in to add a comment. Not a member? Join today