[SOLVED] ifort compiler source problems

[SOLVED] ifort compiler source problems

Hey guys, new here, but I've installed the compiler before, but not on Ubuntu 10.10. So I got it installed and have been trying to compile, however, I have to type

source /opt/intel/bin/ifortvars.sh ia32

every time I open a new terminal. I've tried placing that same line at the end of my ~/.bashrc file with no luck. Like I said, I've installed this before on 10.04 and 9.10 with little to no problems.Thank you in advance for any help you can give me.Logan

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Interesting, have you tried placing this at the top of your .bashrc? You can also add it to /etc/profile or /etc/bash.bashrc as a test, but again, put it near the top. this is because some conditionals may early exit the scripts.

You are using bash shell, right? echo $0 will return your shell


Yeah, I am using bash and I believe I fixed it. I just had to put the source line after the first command in the .bashrc file and it was good to go. It loads that file every time I've tested closing and opening and new terminal. So we'll see if it holds through a restart. If not, I'll be back, but I expect it to work. Thanks a ton, Ron!Logan

Leave a Comment

Please sign in to add a comment. Not a member? Join today