ifort: error #10149: option '-cxxlib-gcc' not supported with the current installed GCC

ifort: error #10149: option '-cxxlib-gcc' not supported with the current installed GCC


I had to change my MacBookPro, so I imported the user from the old one.
The ifort was not working. So I tried to fix the first error, but then another one occured.
So, first I had the following error:

ifort: error: could not find directory in which g++ resides

I fixed that setting the GX_ROOT environmvent variable.

Now I have the following error:

ifort: error #10149: option '-cxxlib-gcc' not supported with the current installed GCC

I read that I have to remove this -cxxlib-gcc option from my ifort command.
But I cannot find where / how to do that!

Using ifort -no-cxxlib does not work. same error occurs.

Thank you very much,


Program versions:

ifort -V
Intel Fortran Compiler for applications running on Intel 64, Version 10.1 Build 20080312 Package ID: m_fc_p_10.1.014

Copyright (C) 1985-2008 Intel Corporation. All rights reserved.

gcc-4 --version
gcc-4 (GCC) 4.3.0
Copyright (C) 2008 Free Software Foundation, Inc.

g++-4 --version
g++-4 (GCC) 4.3.0
Copyright (C) 2008 Free Software Foundation, Inc.

ProductName: Mac OS X
ProductVersion: 10.6.7
BuildVersion: 10J4139

(the OS X version on the old laptop was the one from 2008. don't rememebr now)

echo $GXX_ROOT

17 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

That is a really old fortran compiler designed for Tiger and Leopard and Xcode 2.x and 3.0. I doubt you will get it to work, even if you can get past error 10149. Apple has changed the object file format a few times since then, so the objects the old 10.1 creates probably won't work with the new linker.

Still, if you want to get past this, check that you have the 32bit versions of gcc and g++ on the system - the version 4.3.0 you show doesn't seem standard unless you have installed the most recent xcode 4.1. Check that your libstdc++.6.dylib has i386 verison ( file /usr/lib/libstdc++.6.0.9.dylib )

then try

ifort -dryrun hello.f90

to see all the options used by the compiler. cxxlib in not in the defaults. Try 'alias ifort' to see if some alias is nabbing you.

And you are just trying a simple compile on the command line (NOT in Xcode) of a simple hello world like

ifort hello.f90

and NOT some makefile that may have an option buried somewhere in the defines.

But even after all this, your chances of getting 10.1 to work on Snow Leopard with such a new gcc and binutils are close to nil.

I fear you will need to upgrade to the 12.0 compiler.


Hi Ron,

thank you so much for your reply!
I think I will buy a new version of ifort.
I don't think I am going to chase this problem with such a small chance to make it.

For the records, ifort -dryrun hello.f90 gives this:

ifort: error #10001: could not find directory in which g++ resides
rm /var/folders/w7/w75lLj5AGJ4dDx8hiNV7Kk+++TI/-Tmp-//ifortsTrYY5sw_vers

rm /var/folders/w7/w75lLj5AGJ4dDx8hiNV7Kk+++TI/-Tmp-//ifortcXDG0Ylibgcc

rm /var/folders/w7/w75lLj5AGJ4dDx8hiNV7Kk+++TI/-Tmp-//ifortMvVh6Mgnudirs

rm noname

while 'alias ifort' doesn't even work.

Thanks again,


You can try out the new compiler for 30 days free, just to make sure the new system is working correctly with the compiler:


another thing the new compiler buys you is support and optimization for the new 2nd generation Core i5 and Core i7 processors. the older 10.1 would not have optimized well for these processors.

if you have any -x options, try -xhost instead. this will optimize for the processor you use to compile.


Hi Ron,

I am not sure if I can ask here or there's a special forum.
I downloaded the 30-day trial version of the ifort compiler 12.0 and the redistributable libraries.
I installed both.

I tried: ifort example.f90 -o a.x
and I got:
ifort: error #10310: Failed to enable trusted storage check for licensing: WARNING: Enable Trusted Storage failed (flexnet error code 1). Trusted Storage based license could not be supported

I then tried:
source /opt/intel/composerxe-2011.4.184/bin/ifortvars.sh intel64
ifort example.f90 -o a.x
and I got:
ifort: error #10001: could not find directory in which g++ resides

So I tried:
export GXX_ROOT=/sw/lib/gcc4.3/lib/gcc/i686-apple-darwin9/4.3.0/
ifort example.f90 -o a.x
and I got:
ld: No such file or directory

I have no idea how to fix this.
As far as I understand, ifort is looking for libraries in the wrong place. Maybe
I simply have to change some path from the previous 10.1 version to the present 12.0.
I am just guessing.

Thank you very much,



The compiler installation is very sensitive to the Xcode versions. What version of Xcode do you have installed?

And the 'trusted storage' is a place it puts the evaluation license. Let me see if I can find out where that is. Licenses TYPICALLY would go in /Users/Shared/Library/Application Support/Intel/Licenses. Some other applications have been known to set read-only to the 'Application Support' folder. Try to 'touch' or create a file under that Licenses/ folder to make sure you have permissions to write there.


Here is a similar thread on this forum with an answer, see if this helps:


Hi Ron,

thanks for your help.
I think it's not a problem of License.
Anyway, I copied the License file where suggested.
I still have the same problem.
To make it clearer, I summarize below.
After typing

source /opt/intel/composerxe-2011.4.184/bin/ifortvars.sh intel64

I don't have the "trusted storage" problem anymore.

And the "error #10001: could not find directory in which g++ resides" error is gone after
I typed

export GXX_ROOT=/sw/lib/gcc4.3/lib/gcc/i686-apple-darwin9/4.3.0/

Now I am simply left with the following error:

ifort example.f90 -V

Intel Fortran Intel 64 Compiler XE for applications running on Intel 64, Version Build 20110503
Copyright (C) 1985-2011 Intel Corporation. All rights reserved.

ifort: NOTE: The evaluation period for this product ends on 22-jul-2011 UTC.
Intel Fortran 12.0-1310
ld: No such file or directory

I use the compiler from the terminal.
I don't know what it means using the compiler from Xcode, sorry. I never used that.
What I know is that I had to install the Xcode tools that came in a CD with my MacBookPro.
I launched Xcode and the version is 3.0

What could I do?

Thank you so much for your time!



I see that you installed your own gcc 4.3 build. Apple is still at 4.2.1 and that is what we've tested against. Our support is around the linker and gcc/g++ provided by Apple in Xcode. The version of the compiler you have is checked out against Xcode 3.2.5, but I have it working fine with Xcode 4.0.

Linkers are also important. The linkers in Xcode 3.2.2, 3.2.3, and 3.2.4 had issues. These were fixed by Apple in the linker bundled in Xcode 3.2.5. So that one is a minimum. Apple used to have Xcode 3.2.5 available on Developer.apple.com - I'm not sure if they still have 3.2.5 there. And I'm not sure the linker you have in Xcode 3.0 supports Snow Leopard - I'd have to research.

Our latest compilers work well with Xcode 4.0.x, which you can purchase on through the App Store for USD $4.99. This will have a linker that works with the version of the compiler you have. BUT this still has gcc 4.2.1. Is there a reason you NEED gcc 4.3 ?

I would think your gcc 4.3 would need a compatible linker. Have you compiled a hello world in C or C++ with this compiler, linked it, and had it run successfully? The error you mentioned above: "ld: No such file or directory" indicates that the link phase of your compilation failed to find the linker ld. Again, that comes with Xcode or 'binutils' but not with gcc/g++.


Hi Ron,

I will download Xcode 4, then.
I see that I have both gcc 4.3 and 4.2 in the following directories:


I do not remember why I installed the gcc4.3. Maybe to match something else.

How can I make ifort use gcc4.2?

I tried to compile the hello.c and got this:

ifort hello.c
ipo: error #11025: Linker command line is badly formed
ifort: error #10014: problem during multi-file optimization compilation (code 1)

Thanks a lot,


Make sure that you can build

gcc hello.c

and that g++ -v and gcc -v are consistent. ifort and icpc will use whichever gcc development system is active on PATH.

ifort will not invoke a C or C++ compiler, as gfortran would do. It will build only Fortran source code. You must specify the correct compiler.

The recommendations given earlier tell you which Xcode distributions have been tested sucessfully with Intel compilers.

At least part of the problem here is that you tried to compile a C program with the Fortran compiler.

Can you try

ifort hello.f90

Did that one work better?

-- Lorri

PS: I do that all the time too, which is how I recognized it. :-)

Hi TimP and Ron,

I finally decided to start it over from scratch. Now it works!
Importing the files from the old MacBookPro brought to too many problems.
So, here it goes very easily with a brand new OSX installation.

1) OSX Snow Leopard comes with Xcode 4.0.2 and gcc/g++ 4.2.1
(importing from the old laptop made me use Xcode 3.0 and gcc 4.3; I couldn't overwrite
Xcode with the 4.0.2 that is in the DVD that comes with the MacBookPro)
2) I installed the 30day trial ifort 12.0
3) Copied the Licence file to the directory
/Users/Shared/Library/Application\ Support/Intel/Licenses/
(It won't work without thi step!)
4) now ifort it's working!

I wonder if I have to install the image disk called "m_fcompxe_redist_2011.4.184.dmg" that came with
the ifort.dmg file. Do I need it?

Thanks a lot! With your help I understood what was wrong.
Now I have to install the lapacks and I hope it will work.

Thanks again and have a great weekend! :D


Hi Lorri!

Thanks for the hint! I didn't even noticed! :)
As you can read in my previous post, the problem was that
I imported the data from a previous MacBook, running another OSX and
other versions of the applications. I couldn't overwrite them, so I started from scratch.
Now it works!

Have a nice weekend,


Hi Ron,

I have one more question about ifort and gcc.
I have now ifort 12.0 working on Leopard 10.6 with Xcode 4.0.2 and gcc 4.2.1.
I need a graphics tool called "grace". I couldn't manage to compile the sources myself,
so I could try with "fink". Fink needs to install gcc 4.4, to make grace work.
Do you think this will ruin the ifort?

Thank you very much,


If it were not for the finicky reputation of Xcode, I would say gcc 4.4 should work with ifort, if you install g++ and gcc together. You should be prepared to return to your current configuration; if fink has the flexibility it ought to have, install the new gcc in a separate directory.

Hi Tim, Hi Ron,

ifort 12 is still working after I installed gcc4.4.
It seems that the system is still using gcc 4.2.1, though.

Anyway, it's working.

Thank you very much for your support. Both of you.

Have a nice day!


Leave a Comment

Please sign in to add a comment. Not a member? Join today