Coarray error with mpiexec

Coarray error with mpiexec

I'm running a simple Coarray program but an error occurs at runtime.

[examples]:20 $ ifort -coarray coarray.f90 
[examples]:21 $ ./a.out 
mpiexec was unable to launch the specified application as it could not find an executable:

Executable: -genv
Node: ubuntu-desktop

while attempting to start process rank 0.

I've installed OpenMPI on my Linux system and is it clashing with Intel's builtin MPI ?

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Yes, if the OpenMPI is first in your PATH you will have issues.

Do this:

which mpiexec

should show a path to the compiler's bin like this

Make sure to source /opt/intel/bin/ intel64

this SHOULD put the Intel binaries first in PATH. But check your .bashrc or .profile to make sure you are not setting the OpenMPI path in those.


Thanks Ron ! Changing my PATH variable manually fixed it.
As a side note, sourcing ' ia32' didn't fix the problem. Indeed Intel binaries were first in the list but the mpirt/bin directory wasn't in the PATH.

[shell] $ source $HOME/intel/composer_xe_2011_sp1.6.233/bin/ ia32
[shell] $ echo $PATH
/home/username/intel/composer_xe_2011_sp1.6.233/bin/ia32:/home/username/bin: ... 

As you can see the mpirt/bin/ia32 isn't prepended to $PATH. Probably this is a bug ?

-- Satish

It puts the MPI path at the end.

Steve - Intel Developer Support

Oh I see, Thanks Steve. I overlooked it. I wonder why is it put at the end, instead the beginning.--Satish

it's a hard choice where to put it. If you put it first in the path, then regular Fortran users who do NOT use Coarray but do use their own MPI, like MPICH or OpenMPI, get the Intel MPI instead of their own MPI. And currently there are more users like this than there are Coarray users.

Our initial implementation put the Intel RTL first in the path, and we got a lot of bug reports from MPI users.


Leave a Comment

Please sign in to add a comment. Not a member? Join today