Ifortran use in different user accouts

Ifortran use in different user accouts

Hi,I installed ifortran in ubuntu OS recently and compiled program using a make file using 'make' command.Then I created another user account in the ubuntu os and tried to compile the same program in the new account. But ifortran gives me the message that it does not recognize the make command. Any one know the what is the problem here? Thanks!ALD

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

make is a gcc utility. Did you "source" the Intel compilervars.sh file in the other account?

Retired 12/31/2016

As stated, this doesn't entirely make sense. Did you source the compilervars script under the other accout before trying make? ifort doesn't know anything about make, but your Makefile should run ifort.

It would help if you were more specfic about the the error messages that your received.

Why should the Fortran compiler recognize the make command? Compilers do not have any need to call make.

Or did you mean to say that make was unable to run the Fortran compiler?

Thank you for all your commets.I got the porblem solved. I had to st the path in the in account.ALD

Leave a Comment

Please sign in to add a comment. Not a member? Join today