installation problem

installation problem

hello

I have a problem to install Intel ® Fortran Composer XE 2013 for Linux;

I have an Ubunto 12.O4 lts, 32 bit, the installation completes successfully

and at the end I added to the file ~ /. bashrc "source / opt/intel/composer_xe_2013.0.079/bin/compilervars.sh ia32 "  and I close the file after I open the terminal

I write ifort the result is" ifort: command not found ",

I write man ifort the result is" No manual entry for ifort "

I do not know what to do

please please I need your help

25 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I have already did
sudo apt-get install build-essential
apt-get install gcc-multilib
sudo apt-get install rpm
apt-get install openjdk-6-jre-headless

This very likely is the well known installation issue we currently face for 13.0. See http://software.intel.com/en-us/forums/topic/328087 in this forum and also http://software.intel.com/en-us/forums/topic/327606 for workarounds. I will let you know as soon as a fix is available.
Heinz

thank you very much for your answer

but what is the version of linux compatible with Fortran Composer XE 2013?

Ubuntu 12.04 and 11.10 are offcially supported by compiler version 13.0; the fix of this bug in the next update will make sure, installation and use will not require workarounds

We investigated the problem in more detail: The problem only occurs in case the RPM manager is installed which is unusual for Ubuntu/Debian. This is why our evaluation failed to detect the problem. To improve our testing, it would be helpful to understand, why you had to install the RPM manager. Any feedback would be great. Thanks a lot

if I don't install rpm it will work ?

Yes - in case you don't install the RPM manager, the installation will work even without the workarounds

it doesn't work :(

Here the steps which should make sure, the installation works until we have fixed the issue in update 1 of Composer 13.0:

$ sudo rm /bin/sh
$ sudo ln -s /bin/bash /bin/sh

In case you tried to install the Composer XE 2013 package already, follow these 2 steps:

1. Remove the partially installed Composer package:

$ sudo /opt/intel/composer_xe_2013.0.079/bin/uninstall.sh
You might get an error message "Package has been installed by another user. Press enter to exit";
In this case remove the installation directory:
~$ sudo rm -rf /opt/intel/composer_xe_2013.0.079/

2. You very likely have a corrupted RPM-date base file /root/.rpmdb. The installation will not work without removing this file. Thus
$ sudo –s
# mv /root/.rpmdb /root/.rpmdb.backup
# exit

Now Install Composer XE 2013 in the usual way

$ sudo rm /bin/sh
$ sudo ln -s /bin/dash /bin/sh

Please let us know in case it still doesn't work; please add details like error message etc.

hello Mr.HeinzB
I reinstalled Ubuntu and i did what you asked me for

apt-get install build-essential
apt-get install gcc-multilib
apt-get install openjdk-6-jre-headless

and after

bendaou@bendaou-Compaq-610:~$ sudo rm /bin/sh
bendaou@bendaou-Compaq-610:~$ $ sudo ln -s /bin/bash /bin/sh
$ : commande introuvable (command not found)
bendaou@bendaou-Compaq-610:~$ sudo -s
[sudo] password for bendaou:
bash: /usr/bin/lesspipe : /bin/sh : mauvais interpréteur: Aucun fichier ou dossier de ce type (bad interpreter: No file or directory of this type)
root@bendaou-Compaq-610:~# mv /root/.rpmdb /root/.rpmdb.backup
mv: impossible d'évaluer «/root/.rpmdb»: Aucun fichier ou dossier de ce type (impossible to evaluate) «/root/.rpmdb»: No file or directory of this type)
root@bendaou-Compaq-610:~# exit
bendaou@bendaou-Compaq-610:~/Bureau/l_fcompxe_2013.0.079$ sudo ./install.sh
bendaou@bendaou-Compaq-610:~/Bureau/l_fcompxe_2013.0.079$ ./install.sh
bash: ./install.sh : /bin/sh : mauvais interpréteur: Aucun fichier ou dossier de ce type (bad interpreter: No file or directory of this type)

installation doesn' pass

I'm not sure whether you really linked /bin/bash to /bin/sh. You added the '$' in typing the command ( see your latest post). Please try again ( no need to re-install your OS):
sudo ln -s /bin/bash /bin/sh
sudo –s
mv /root/.rpmdb /root/.rpmdb.backup // ignore error message in case file should not exist
exit
sudo /bin/rm -rf /opt/intel/composer_xe_2013.0.079/
< do the compiler installation >
sudo rm /bin/sh
sudo ln -s /bin/dash /bin/sh

finally it works thank you very much
I added in the bashrc:
/opt/intel/composer_xe_2013.0.079/bin/compilervars.sh ia32
PATH=$PATH:/opt/intel/composer_xe_2013.0.079/bin/
export PATH
/opt/intel/composer_xe_2013.0.079/bin/ia32/idbvars.sh
PATH=$PATH:/opt/intel/composer_xe_2013.0.079/bin/ia32/ifort
export PATH

Great to see this !
A note: You should not 'execute' the compilervars.sh script but 'source' it. That is do:
source /opt/intel/composer_xe_2013.0.079/bin/compilervars.sh ia32
Then there is no need either to set $PATH again - the script is setting this for you correctly

yes you are right thank you
please you have an idea about this error :

source/specx.f(78): error #7911: Adding this variable to common-block-object-list causes the common block size to exceed the maximum of 2147483647 bytes

You have exceeded the size of static storage for a 32-bit address space. If you are on an x64 system, try adding "-mcmodel medium" to the compiler switches. I would also suggest that rather than putting huge arrays in COMMON that you use allocatable arrays instead.

Steve - Intel Developer Support

hello Mr.Steve Lionel
I changed ubuntu 32 bit to ubuntu 64 , I installed ifort and i compiled my makefile
;;;
the problem is that the program is a makefile. it's already programmed by the author and I can't change the content ( I sent you the program)

and here is the error
bendaou@bendaou-Compaq-610:~/Bureau/cpa2002v009c$ make
ifort -O3 -o source/specx.o -c source/specx.f
source/specx.f(44): error #6502: COMMON cannot be extended beyond the beginning of a block. [WKC]
& ,wkc(1),detl(msex,2),det(lengx)
-----------------^
compilation aborted for source/specx.f (code 1)
make: *** [source/specx.o] Erreur 1

pleaaase !!!
i need your help

Attachments: 

AttachmentSize
Downloadapplication/x-tar cpa2002v009c.tar580 KB

This indicates that you have inconsistencies in the layout between instances of the COMMON (or perhaps the source code is corrupted). It seems to say that wkc(1) has been tacked on to the beginning of a later version of the COMMON.

update 1 of Composer 2013 ( version 2013.1.117 ) is available for download now at registrationcenter.intel.com. This version fixes the installation issue reported in this thread
Heinz

Bendaou O: I went through the same trouble u have had trying to compile the cpa2002 with intel fortran. you can change the makefile (it's legal) as the author of the code even gives these rights, he even put comments ### for alternatives as the code is platfrom dependenI . I followed Steve's suggestion by adjusting the compiler switch as -mcmodel=medium (and large) (you can do that by going to the makefile and put          flag  =  -03 -mcmodel=medium or flag = -03 -mcmodel=medium -i-dynamic as suggested in some other places) ... well it just doesnt produce the executable specx u are looking for ........... I tried the fort77 (your can easily install it in ubuntu : sudo apt-get install fort77 and change the flag to fort77) but produces errors ......... the only compiler that worked for me ,though with a poor performance compared to what someone would expect from ifort , is gfortran (again which u can easily install from ubuntu repositories) ..  if I figure out how to run it using intel fortran , I will let u know. 

Check my reply in machikaneyama .... 

The error reported in reply #17 (marking the original post as #0), namely, COMMON cannot be extended beyond the beginning of a block appears to be a bug in IFort 13.0.1.117. Since this thread started with a seemingly unrelated subject heading, I posted a small reproducer in a new thread: http://software.intel.com/en-us/forums/topic/357718 .

I was able to build and run the application easily using the makefile provided, with the options -O3 -shared-intel -mcmodel=large using older versions of the compiler: 11.1.080, and 12.1.7.367, on Suse Linux X64 12.2.

that's right....  -O3 -shared-intel -mcmodel=large  doesn't do it?


I escalated the #6502 error as issue DPD200240073.

Steve - Intel Developer Support

The #6502 issue is expected to be fixed in Update 3 (late March.)

Steve - Intel Developer Support

Leave a Comment

Please sign in to add a comment. Not a member? Join today