ifort: command not found

ifort: command not found

The problem that I'm experiencing seems to have been reviewed in these forums quite a bit but those solutions haven't solved it for me for whatever reason. My problem is that when I call ifort I receive a "command not found" response.  I successfully installed the compiler and then called compilervars.sh ia32 but still nothing.  I even tried creating a "custom.sh" file in etc/profile.d/ and then putting <install dir>/ifort but that didn't work either.  Does anyone have an idea as to what my problem is?  Thanks so much.

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

If you run the shell script compilervars.sh directly, it will set the necessary environmental variables, but the old environment is reinstated as soon as the shell script completes.

The proper command to use is

source compilervars.sh ia32

Yes, that worked. Thanks so much.

Leave a Comment

Please sign in to add a comment. Not a member? Join today