Error in opening the compiled module file

Error in opening the compiled module file


 when it is compiled, it shows many errors such as:

mpif90 -c -O3 -ip -convert big_endian -assume byterecl -heap-arrays -r8  -I/usr/local/netcdf/412_intel11/include -DOASIS3 -I/data14/hhno/speedy_nemo/speedy_nemo/Linux_MPI1/build/lib/psmile.MPI1  -I/data14/hhno/speedy_nemo/speedy_nemo/Linux_MPI1/build/lib/clim.MPI1 -I/data14/hhno/speedy_nemo/speedy_nemo/Linux_MPI1/build/lib/mpp_io print_obs.pp.f90 -o print_obs.o print_obs.pp.f90(3): error #7002: Error in opening the compiled module file.  Check INCLUDE paths.   [DATE_UTILS]    USE date_utils

error #7002: Error in opening the compiled module file. Check INCLUDE paths.

I use MPICH v1.2.7(/usr/local/mpich1/intel11) and Netcdf v4.1.2 (/usr/local/netcdf/412_intel11)

What are the possible problems?

Thank you in advance.


4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

It seems that you have a USE referring to a .mod file which isn't found on your include paths. Among possible reasons:
netcdf wasn't built first and installed in the include path you quote
date_utils.mod wasn't built with the same compiler version as the one which is trying to read them ( check mpif90 -V and ifort -V )

Thank for your comment.
I checked mpif90 -V and ifort -V. compiler version is same.
But I got another error code.

mpif90 -c -O3 -ip -convert big_endian -assume byterecl -heap-arrays -r8 -I/usr/local/netcdf/412_intel11/include -DOASIS3 -I/data14/hhno/speedy_nemo/speedy_nemo/Linux_MPI1/build/lib/psmile.MPI1 -I/data14/hhno/speedy_nemo/speedy_nemo/Linux_MPI1/build/lib/clim.MPI1 -I/data14/hhno/speedy_nemo/speedy_nemo/Linux_MPI1/build/lib/mpp_io enactdata.pp.f90 -o enactdata.o
enactdata.pp.f90(2): error #7002: Error in opening the compiled module file. Check INCLUDE paths. [TOOLSPAR_KIND]
USE toolspar_kind
enactdata.pp.f90(17): error #6683: A kind type parameter must be a compile-time constant. [DP]
REAL(KIND=dp) , DIMENSION(:) , POINTER :: p_lam !: latitude
enactdata.pp.f90(578): error #6404: This name does not have a type, and must have an explicit type. [DP]
& -180.0_dp)/=nf90_noerr) THEN
enactdata.pp.f90(578): error #6975: A kind-param must be a digit-string or a scalar-int-constant-name [DP]

compilation aborted for enactdata.pp.f90 (code 1)
gmake[1]: *** [enactdata.o] Error 1
gmake[1]: Leaving directory `/data14/hhno/speedy_nemo/speedy_nemo/nemo_build/ifort_oasis3/opa.ORCA2_OASIS3.1.1'
gmake: *** [tools] Error 2

Should I add include path in *.F90 ?

I will very appreciate if you give me some advice.

The file toolspar_kind.mod must exist before you can compile any sources that USE that module.

1. Check that the file that contains the source code of the module has been compiled.

2. Check that the resulting module file is accessible through the INCLUDE path list.

Leave a Comment

Please sign in to add a comment. Not a member? Join today