Potential loop unrolling bug in ComposerXE 2013

Potential loop unrolling bug in ComposerXE 2013

I have found a potential bug with the loop unrolling of a triangular loop.  The example is attached. 

[marianne@MarianneFedora15 ~]$ ifort -v
ifort version 13.0.1

[marianne@MarianneFedora15 ~]$ ifort loopUnrolltest.f90
[marianne@MarianneFedora15 ~]$ ./a.out
   1000000.       1000000.      3.3835000E+07  0.0000000E+00  0.0000000E+00
[marianne@MarianneFedora15 ~]$ ifort -unroll0 loopUnrolltest.f90
[marianne@MarianneFedora15 ~]$ ./a.out
  3.3835000E+07  3.3835000E+07  3.3835000E+07  3.3835000E+07  3.3835000E+07

Downloadapplication/octet-stream loopunrolltest.f90564 bytes
6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Bug report entered.  We will inform you when a fix gets into the compiler.

Thank you for such a good concise reproducer!  This really helps us.


I am just glad I was able to actually reproduce it separately from our main code.  That does not usually happen! 

Thanks for submitting the bug report.

Is it possible to get a ticket number or something for this issue?  My management has asked me for one.  I had issues logging into the premier support to submit this myself which is why I posted it here in the first place.

The internal bug report id Ron filed for the issue is DPD200240713

this bug was fixed in Composer XE 2013 Update 3, aka build 20130313.

thank you for reporting this bug.


Leave a Comment

Please sign in to add a comment. Not a member? Join today