Failure during allocation - Intel Fortran 11.1.056 (Linux)

Failure during allocation - Intel Fortran 11.1.056 (Linux)

Hello,

This is a hybrid MPI-OpenMP code being compiled with Intel Fortran 11.1.056. I'm getting runtime failure on an allocate statement when I run on 4 MPI ranks with 1 OpenMP thread per rank (when I run on 1 MPI rank it runs fine). Each rank is allocating the variable (size 121). I check to see if the array has been allocated just before allocation and also check for status. On all 4 ranks it has not been allocated (I know from the check if(.not.allocated(A)...). On 3 ranks it is able to allocate the array and return 0 for status but on the fourth (rank #3) it dies during the allocate statement, doesn't even get to the status check part.

I use these options to compile: ifort -O2 -check all -traceback -warn all -fstack-protector -assume protect_parens -c file.F

Any pointers would be appreciated.

Thanks.

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Any (reproducer) code would be appreciated.

Are you allocating an array or pointer to array?

Is the context or object containing the array descriptor or pointer contained within the MPI rank of the issuing processor?
IOW are the acessors to your allocations contained within the MPI rank?

If you compile with OpenMP set to single (stubs) does the code work?

Jim Dempsey

www.quickthreadprogramming.com

Leave a Comment

Please sign in to add a comment. Not a member? Join today