Need to install Intel fortran 10.1 or 11.1 in Ubuntu 13.04, is it possible?

Need to install Intel fortran 10.1 or 11.1 in Ubuntu 13.04, is it possible?

       I'ḿ using a software (Abaqus 6.10) that only supports intel fortran compiler 10.1 or 11.1 .

When I try to make it, i got this error message:

"32-bit libraries not found on this system.
This product release requires the presence of 32-bit compatibility libraries
when running on Intel(R) 64 architecture systems. One or more of these libraries
could not be found:
Without these libraries, the compiler will not function properly.  Please refer
to Release Notes for more information."

I'ḿ sure that I've  downloaded the intel 64 bit version of the compiler. So i don know why i got this error message.

thank you =)

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Recent versions of 64-bit Linux distros don't include, by default, tools and libraries for building 32-bit applications. You need to get and install the 32-bit gcc tools first.  But if you don't want to develop 32-bit applications, then download and install the "Intel 64" compiler - you have either the "IA-32" compiler only or, maybe, the installer that has both, though I'd think the latter would allow you to skip the 32-bit install.

Steve - Intel Developer Support

I tried to install the 32-bit gcc tools by the command  "sudo apt-get install gcc-multilib". it still doesn't work. I tried to install the other versions of the compiler as you said, but it doesn't alow me to skip the 32-bit install. Thank you anyway.

Redo the install and select the "custom" instal where you select the components to install, then skip the 32-bit compiler. But I will comment that those compiler versions don't know about Ubuntu 13 and may not work properly on it. (Linux distros are notorious for version-to-version incompatibilities.)

Steve - Intel Developer Support

I'm having difficulty remembering which version of ifort introduced the ability to install the Intel64 compiler without requiring both a 64-bit and 32-bit g++, but I think it was more recent than 10.1.  It was nearly impossible to install 32-bit ifort and icc 10.1 together on Ubuntu 64-bit.  Ubuntu 13 came out after those Intel compiler versions were superseded.

Unless Abaqus has specific advice about which Intel compilers are suitable with your Ubuntu, If they even support their old version on the new OS, you may have fewer problems using an ifort version intended for more recent Ubuntu.  Their statement about wanting ifort 11 simply indicates that is the newest they tested with that version, not that a newer one wouldn't work.   Similar questions would arise about your OS version.

This forum can't really fill in the gap if you don't have entitlement to Abaqus support.

Leave a Comment

Please sign in to add a comment. Not a member? Join today