Where is the license file during the evaluation period?

Where is the license file during the evaluation period?

I installed a trial version of Intel Composer XE 2013 (for Linux) as root and after the install root can run the compilers. However, no other users are able to. I thought it was odd that all the directories being written did not allow other users read or execute permissions. After an uninstall, I changed the umask and SELinux to allow more permissive writing and the directories are written so others have read and execute permissions. However, users were still unable to use the compilers.

Calling ifort as a non-root use results in "Error: A license for FCompL is not available (-76,61026,2)... ifort: error #10052: could not checkout FLEXlm license". I checked all the directories listed in this error and in the environmental variable INTEL_LICENSE_FILE and all the directories that exist are empty.

I am assuming that on my first install (when the umask/SELinux was restrictive) a license file was created somewhere that only allows root to read it. However, during my re-installs the permissions on said license file are not changing.

Is the license file installed somewhere outside of /opt/intel? Where is it so I can loosen the permissions with chmod or delete and reinstall? Or are there other options to get around this problem?

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

If you opt to evaluate without a serial number, the license system uses some form of "trusted storage" to hold the license information, not a license file. If you were issued a serial number, register it at https://registrationcenter.intel.com/ and a license file will be emailed to you. I will comment that we license the compiler under a "single user" license, which means only the person to whom the license was issued may use the product.

Retired 12/31/2016

Is there a way to modify the "trusted storage" to allow all users, not just root, can use the compiler?

I tried to use the link (as I had before posting this) and got:

"Our records indicate that the serial number you provided has already been registered. Please check your records and try again. If you feel you have received this message in error, Click Here."

I've tried entering the same serial number during the install and the installer gave me a Activation Code to enter at https://registrationcenter.intel.com/RegCenter/remoteactivation.aspx in order to get an Unlock Code. However it gave me an error regarding evaulation serial numbers not being able to get Unlock Codes.


Nevermind, I was able to find the trusted storage under "/usr/local/share/macrovision" and rename it. Once I ran the install scripts again (this time with umask set more permissively) everything worked.

Leave a Comment

Please sign in to add a comment. Not a member? Join today