XE 2013 sp1

XE 2013 sp1


I am trying to compile Ncar Graphics:


This has worked in the past, but I can't get it to work using XE 2013 SP1. I went back to an earlier version of the compilers and was able to get a sucessful build. After the build there is a simple test that is ran. It worked under 2012, but not under 2013. I have worked with the suppliers of the software and we have narrowed my problem to a particular piece of code. It compiles under 2012, but not under 2013. Thanks

8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

It might be preferable to file an issue on premier.intel.com, if you don't want to give specifics here.  There are already 3 releases of ifort XE 2013 SP1 of progressively improving stability, with multiple OS and architecture targets. I see on the order of a dozen releases of the software in question, with possibly exponential combinations with requred libraries and confusing instructions about downloading.

I don't mind posting the specifics here. I went back to XE 2012 and I was able to compile and test the software. I used the same method to compile with XE 2013 sp1. Some of the generated software worked, some didn't.Basically from the software providers, I was told there is a program that generates Fortran code. That program isn't produced correctly, and then generate incorrect code. I have some users who can use gcc and gfortran, others require PGI, and still others use Intel. In this case we have Intel hardware we would like to take advantage of. We have purchased the software, but that was before my time and I am not sure it is under support. Could be, just not sure. The file labeled as 'mine' is from the provider.


Downloadapplication/octet-stream CodeFortranmine.f193.65 KB
Downloadapplication/octet-stream CodeFortranyours.f194.93 KB

CodeFortranyours.f contains invalid source starting at line 742 compared to the CodeFortranmine.f that you indicate the providers provided you. The lines starting at line 742 in yours contain syntax errors. There are subsequent lines in yours are also invalid, like 755, 761 and others and this is why the CodeFortranyours.f is not compiling. It does not compile with our Composer XE 2012 or 2013.

For us to investigate we need to know exactly the steps you used to build and test the NCAR graphics package and steps/tests that produced the CodeFortranyours.f source file so we can try reproducing the issue.

In terms of building, perhaps you can comment on whether you followed the steps outlined in our Building NCAR Graphics* with the Intel® compilers

Thank you

Yes Kevin. I had seen those step 'Building NCAR Graphics with the Intel Compilers' and even completed on the thread. I can go back and try another build today. When I did my sucessful build with 2012 I captured the output


Downloadtext/plain make-output.txt1.47 MB

Thank you Greg. I had not seen the additional user comments on the article. It appears versions in the article are a bit behind the current NCAR versions. From your makefile I noted you are building the latest NCL 6.1.2 so I'll get started trying the build process myself and update after I learn more.

Thank you for your help. I am more than willing to install the latest version of the Intel compilers if that is the issue.

Ok, I successfully built NCAR Graphics 6.1.2 and ran the cpex08 example using both the Intel® Composer XE 2013 SP1 Update 1 (Version Build 20131008) and Update 2 (Version Build 20140120) releases.

The only trouble I ran into was covered under item 4 on the NCAR NCL Download page in the Troubleshooting and known problems section involving suffering unresolved references to gziqwk_ and gztowk_ when building the cpex08 sample. In my case, to rebuild the libncarg_gks.a following their three required steps also required adding an additional include path (/usr/include/freetype2) into the Makefile for cdrivers. Once that library was rebuilt the cpex08 example built and ran just as described on our build instructions article that I inquired about in my earlier post.

I do not know how the attachments you provided earlier were created but I was able to find the corresponding source file in my build tree (./src/libncarg/areas/ardrln.f) for the source that was garbled in your case. This source, near the lines that I mentioned in your file was garbled, is fine in my case and matches that which the vendor provided you. I can see in the makefile output where this source file and may others are produced during the build. That yours was somehow garbled indicates something malfunctioned during your build but I was unable to reproduce that and so I don’t know why your source became garbled. The fsplit utility program is used in producing the source file in question so perhaps the failure is with that utility. Since I used their LINUX.64.INTEL configuration file, both the Intel C++ and Fortran compilers were used throughout the build, including building this utility with the Intel C++ compiler.

The only thing I could suggest for building with XE 2013 SP1 is starting over with a fresh source base by unpacking the source tar.gz. If you happened to re-use a previous source base used when building with the XE 2012 release then maybe this somehow introduced the build failures with the XE 2013 SP1 release.

Leave a Comment

Please sign in to add a comment. Not a member? Join today