Inquire statement with -openmp option

Inquire statement with -openmp option

Dear forum,

I actually use Intel composer_xe_2013_sp1.2.144 with openMP.

I separated the following issue from my software project. The program fails to execute in case of using

INQUIRE (FILE= ... , OPENED= ...) together with the -openmp option, see example.

Otherwiese, without -openmp option or without the statement every things works fine.

      PROGRAM test
      IMPLICIT NONE
      CHARACTER(255) :: datei
      LOGICAL :: lopen
      LOGICAL :: lexists
!
      datei = 'dateiname.dat'
!
!     This situation work fine in all test cases.
      INQUIRE (FILE=datei,EXIST=lexists)
!
!     This situation fails if combined with the -openmp option
      INQUIRE (FILE=datei,OPENED=lopen)
      END PROGRAM test

Can somebody comment on this problem? Thankyou

 

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I am unable to reproduce a failure with or without -openmp and with/without the file being present.

$ ifort -V
Intel(R) Fortran Intel(R) 64 Compiler XE for applications running on Intel(R) 64, Version 14.0.2.144 Build 20140120
Copyright (C) 1985-2014 Intel Corporation.  All rights reserved.

$ ifort test.f90
$ touch dateiname.dat
$ ./a.out
$ rm dateiname.dat
$ ./a.out

$ ifort -openmp test.f90
$ touch dateiname.dat
$ ./a.out
$ rm dateiname.dat
$ ./a.out

Are there other compiler options you may be using when it fails?
Can you show the actual error you received when using -openmp?

Dear Sir,

thank you for your effort.

I refined my study and append the full test case, see the appended zip-file.

It does not make a difference in my case  whether the file dateiname.dat already exists.

I also append the executables and the log of the ldd command.

Please advice me to make additional studies.

Best regards

 

 

 

 

Attachments: 

AttachmentSize
Downloadapplication/zip inquire-error.zip541.74 KB

Thank you for the added details. Our programs are almost identical. I can build and run your program with success too. I can even run your executables with success on SLES 11. I don't have the needed GLIBC_2.14 on my RHEL 6.2 to run them there. I'll try some other distros we have available to see whether I can trigger the failure.

What Linux distro and version of GCC are you using?

Dear Mr. Davis,

again thank you for the effort.

I am using openSUSE 13.1 and gcc version 4.8.2.

My last working executable (the large software project, not the test example) dates from February 21, 2014. Everything worked fine using composer_xe_2013_sp1.1.106. After finalizing the examples, I installed composer_xe_2013_sp1.2.144 on February 21, 2014, too. After two weeks of other duties, I came back to programming last week and now face this problem. Nevertheless, other software components offered as update from openSUSE or something else might cause the problem.

I will reinstall composer_xe_2013_sp1.1.106 and check the test case again without any other kind of modification on the system.

I will come back and report my experience.

Best regards

FJB

 

 

 

 

 

Dear Mr. Davis,

I like to confirm the observations I made yesterday after the following tests.

I reinstalled composer_xe_2013_sp1.1.106 and run all tests successfully.

Afterward, (without any other modification to my system) I installed composer_xe_2013_sp1.2.144 and again observe the already described failure. I can only observe it in the combination of -openmp and INQUIRE (FILE=...,OPENED=...)

Thus, anything of openSUSE 13.1 with gcc-Version 4.8.2 20140306 [gcc-4_8-branch revision 208375] (SUSE Linux) or other up-to-now unknown software components might be incompatible to some component of composer_xe_2013_sp1.2.144.

I will go back to composer_xe_2013_sp1.1.106 for the next time. Nevertheless, I would be happy to see this issue solved with the next update.

We have tried and are unable to reproduce the reported failure ourselves and our testing now includes having built/run on an openSuSE 13.1 system. On that system we can also run the executables you provided without any error.

Since you can have multiple versions of the Composer XE 2013 SP1 installed side-by-side, we like to request that you experiment with three different Composer updates. Since you currently have the Composer XE 2013 SP1 Update 1 installed which is working for you, can you please re-install Composer XE 2013 SP1 Update 2 without uninstalling the Update 1, and also download and install the latest Composer XE 2013 SP1 Update 3, again without uninstalling the first two updates.

With the three updates installed, using your simple test case, will you please compile the test case using Update 1 and run and verify that both the sequential and openmp executables run correctly. Next, initialize a different login shell to use Update 2 and then re-run that same executables you built using Update 1, so do not recompile with Update 2. We’re interested in knowing whether the openmp test only fails. As a final test, again using the same executables build using Update 1, now initialize another different login shell to use Update 3 and again re-run that same Update 1 executables and note whether the openmp test only fails. Depending on the results, we may have some follow-up tests to try.

We appreciate your time in helping us reproduce and find the cause of this failure you experienced.

Leave a Comment

Please sign in to add a comment. Not a member? Join today