Redirected Input

Redirected Input

I have a multi-threaded Fortran program that requires redirected input. I am trying to use it as a target in Inspector XE 2011. I am getting an error. I think the problem with with the redirected input. This is being run in Ubuntu Linux.

Below is an example of how to run the program outside of Inspector XE showing the redirected input.
./TEST < input.lst

To simulate the redirected input in Inspector XE I put the following under Application parameters:
< input.lst

I also tried to put the entire execution command, with the redirected input included,into a shell script and reference TEST as the child application. I get the same errors that way too.

When I run analysis I don't think the program is being executed by Inspector XE. I get errors and exit code 137.

When I reveal the command line I do not see the "< input.lst"appear anywhere.Its absence meansthe redirected input isn't happening. How do I get the redirected input to work in Inspector XE?

10 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I'm using Inspector XE 2011 Update 7
# inspxe-cl -version
Intel Inspector XE 2011 Update 7 (build 189290) Command Line tool
Copyright (C) 2009-2011 Intel Corporation. All rights reserved.

I build a simplest application, and used "Redirect Input" (fort_data.txt file includes a character "5" only)
# ./fort_data.ifort < fort_data.txt
Enter number of repeats
x = 1 , y = 1
x = 2 , y = 2
x = 3 , y = 3
x = 4 , y = 4
x = 5 , y = 5

Also there is no problem to run it by usin inspxe-cl:
# inspxe-cl -collect mi2 -- ./fort_data.ifort < fort_data.txt
Used suppression file(s): []
Enter number of repeats
x = 1 , y = 1
x = 2 , y = 2
x = 3 , y = 3
x = 4 , y = 4
x = 5 , y = 5

Is there any special in your application?

Regards, Peter

I followed your example and made a simple program using redirected input. Afterwards I now believe that Insepctor XE isn't working at all. I recently installed Inspector XE and I have not used it before. There were no errors in installing the program, but it clearly isn't working. After running a simple program I get the following messages:

Used supression files(s): []
Error: An internal error has occurred. Our apologies for this inconvenience. Please gather a description of the steps leading up to the problem and contact the Intel customer support team.
Warning: Error: Cannot find input file. Cannot continue.

I think I may not be running Inspector XE correctly or it is not correctly installed.

I built the number of queens example provided with Inspector XE. I built adebug version built with Intel Fortran 2011 (2011.4.191). I enabled OpenMP (-openmp), debug information (-g) and disabled optimization (-o0). I confirmed the program executes outisde of Inspector XE.

I tried to make a project with the Inspecor XE GUI. When I run analysis I get the same errors above.

On the command line I tried the following:
inspxe-cl -collecxt mi2 -- ./queens

I still get the same erros mentioned above. Do you know what can be the problem?

Does Inspector XE work with no "redirect input"program?

If Inspector XE doesn't work at all on your machine, is it possible that Inspector XE works on untested OS? You may check release notes, or try this product on other machine (with different OS).

You can try - (If see any error message)
amplxe-feedback -create-bug-report

Please send me for investigating. (Youmay make the post Private, if message is sensitive)

Regards, Peter

After additional testing I now know that Inspector XE doesn't work at all on my machine. I am using Ubuntu 11.4 - one version newer than the latest approved version. Could that be the problem? When will 11.4 be supported?

Ubuntu* 11.4 is untested OS, please install the product on one of them -
10.04, 10.10 and 11.04

Wait next release and review release notes toknow if version 11.4 is supported.

Regards, Peter

I am using Ubuntu 11.04. Sorry for the typo. Is 11.04 supported?

Yes. Version 11.04 is supported.

I am still having endless trouble getting Inspector XE to work. I think the problem is because on this computer I had Intel Fortran Compiler (Composer XE) 12.0.4 previously installed. I tried to install the latest Compose XE 12.1.0. Then I reinstalled Inspector XE. Finally I got Inspector XE to run, but only if I run it as root in the GUI. Unfortunately, one bad side effect is that now Eclipse (Fortran IDE envrionment) isn't building my applications any more. I will try to reinstall Eclipse with the latest version to try to fix that problem. This is quite frustrating. I feel like I need to wipe my computer and start all with new software. Do you have any ideas why I am having problems?

Inspector XE GUI doesn't use Eclipse, and uninstalling/reinstalling Composer XE will NOT impact existing Inspector XE.

You said, you got Inspector XE to run, but only if you run it as root user on GUI. Is it possible there is permissionproblemof writing in result directory? Try command:
$inspxe-cl -collectmi3 -r /tmp -- application.

Regards, Peter

Leave a Comment

Please sign in to add a comment. Not a member? Join today