Inspector "Error detected during analysis" when Detect Memory Problems

Inspector "Error detected during analysis" when Detect Memory Problems

Hi, 

Today when I run inspector to analysis my project, I met this error.

Before I had not ever met this error.

I had try to reinstall inspector, bug not fixed the problem, and even the whole c_studio_xe_2013_sp1_update2_setup.

I am sure I don't run any defense software.

I have license for  c_studio_xe_2013_sp1_update2_setup

Additionally, my project can run smoothly when not analysis with inspector.

 

My Inspector version is : 

Intel® Inspector XE 2013 update 9

VS version is:

Microsoft Visual C++ 2010

OS version is:

Windows 7

 

The following is the screenshot

 

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Send me the affected result directory in a private message.

Was it possible that this was due to no enough memory to work when Inspector ran?

Did you build 32bit application but running in 64bit system? If so, please use option "/LARGEADDRESSAWARE" to build your 32bit app.

Can you try this in Inspector standalone app (inspxe-gui), or command line (insplxe-cl) ?

Can you set stack-depth=1 to reduce memory consumption from Inspector's monitoring? Or set option "-module-filter-mode=include -module-filter=your-program" for your target module only?

Mark may understand pin log better. Have you sent result directory to Mark?

Sending problematical application to Mark, also will be helpful, I think, if possible.

Still have other thing to try, in command line:

inspxe-cl -collect mi2 -r /tmp/r000mi -module-filter-mode=include -module-filter=your-module -- ./your-app

Will you see same result? Or application exits abnormally?

Leave a Comment

Please sign in to add a comment. Not a member? Join today