Symbol information not found

Symbol information not found

VS 2015 Update 3, Intel Inspector XE 2016 Update 3 (build 460803), Windows 7 64 bit, analyzing a 64 bit program.

When I run the preset analysis "Locate memory problem" from the project node context menu, symbols for the program itself cannot be apparently loaded. When the program completes, a memory leak problem is reported in the Summary tab, but the lower pane says "Symbol information not found. Suggestion" etc. There is only the module name, and a hex address.

The program is built with debug information (I tried both /Zi and /ZI), and I can debug it just fine, the VS debugger loads symbols. Also, Inspector seems to report the location for another (probably bogus) problem of a mismatched allocation, pinpointing the location inside msvcp140d.dll all with source file and line number. It is only my own symbols that cannot be loaded.

How can I proceed troubleshooting from this point on?

Thread Topic: 

Help Me
4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


Is the module name for the memory leak reported by Inspector the main binary of your application or another dll? If it's a library, can you confirm that this library was build with symbols?

It seems that the culprit is the /Debug:FASTLINK linker option that was added to Microsoft's linker in VS 2015 Update 1 (full details

Apparently. Inspector XE is unable to read symbols from a Partial PDB format generated with this option. When I switched to the old PDB generation, the error went away. (/DEBUG without a qualifier :FASTLINK).

I did not test this with Inspector 2017 yet.

You are right. FASTLINK is not supported in our tools currently, you should disable it for Inspector analysis.

Leave a Comment

Please sign in to add a comment. Not a member? Join today