The latest Intel Inspector 2017 update 3 stops working

The latest Intel Inspector 2017 update 3 stops working

After I installed the update 3 of Intel Inspector 2017, it fails with unknown error. It does not matter what analysis type I have and this is the same project that worked fine with update 2.

 

Error: An internal error has occurred. Our apologies for this inconvenience. Please gather a description of the steps leading up to the problem and contact the Intel customer support team.
Error: An internal error has occurred. Our apologies for this inconvenience. Please gather a description of the steps leading up to the problem and contact the Intel customer support team.
 

AttachmentSize
Downloadapplication/zip r001mi2-bad.zip10.07 KB
Downloadapplication/octet-stream realtime_mode.log925 bytes
24 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

 

I see the error. What OS version are you using?

Windows 10. I have not had issues with the previous update.

 

BTW, with the latest updates for VTune Amplifier (Basic Hotspot) and Advisor, I am getting the following errors

__bionic_open_tzdata_path: PIN_CRT_TZDATA not set!
__bionic_open_tzdata_path: PIN_CRT_TZDATA not set!
__bionic_open_tzdata_path: PIN_CRT_TZDATA not set!

Is it possible that Inspector is having the same issue with some PIN incompatible security software ? Since this is a corporate PC and there is no easy way to bypass the security software, is there a way to find the conflicting software before I can proceed to the next step ?

Thx,

Clifton

 

 

Is it possible for you to share the executable that reproduces this issue?

No, this is the firm IP and against policy to share any code. But this is not particular to my code. I get the same errors running the sample code from Intel distribution (tachyeon_insp_xe)

 

Understood.

I am in discussion with our development team... I'll let you know the status

 

Can you run

inspxe-feedback.exe -create-bug-report=c:\temp\report.txt

And send the report to kevin.p.oleary@intel.com

Our current theory is the security software but we would like to confirm. Is there a way for you to exclude pin.exe from the list of software scanned?

Hi,

I have put in an inquiry to the security team to see if it's acceptable to do this. At the same time, I have reverted to the previous version and inspector works just fine and am able to proceed with my work. In the meantime, I will try to install the latest inspector on a different PC and see if I can generate the report for you. This PC actually runs Windows 7.

Regards,

Clifton

 

BTW, I just installed Inspector update 3 on a Windows 7 corporate PC and did not experience this issue. Let me install this again on my PC

Hi Kevin,

I sent you the info as requested and the inspxe-feedback.exe also crashed on my Windows 10 PC. Note that I have Symantec Endpoint Protection running on the Windows 7 corporate PC also and Inspector worked just fine without any issues. I think it's Windows 10 specific. I tried an evaluation version on my home PC, running Windows 10, with virus software disabled, it had the same problem. For the time being, I just have to revert to the previous update.

Regards,

Clifton

 

I will pass this along to engineering and get back to you.

Kevin

 

Hi Clifton,

I wanted to let you know that we have an engineering release of Inspector that we believe will resolve this issue. Would you be interested in giving it a try. Please file a support ticket at http://www.intel.com/supporttickets

Also, for VTune the issue is resolved in VTune 2017 update 4.

Thanks!

 

VTune 2017 update 3 and update 4 doesn't work:

 

Rollback to Vtune 2017 u2 - it works OK.

Windows 7

 

Hi Clifton,

I am escalating the issue with the vtune team.

Kevin

 

Can you verify the vtune build # for update 4... help->about->details

Thanks!

I already use update 2.

I found the problem after installing update 3. After that I found this page and downloaded and installed update 4 - it didn't help, so I pretty sure that Update 4 didn't helped me.

 

BTW: Update 3 works fine on the same task, but on Windows Server 2012 R2

 

Thanks Maxim,

Can you please file a support ticket at http://www.intel.com/supporttickets

Kevin

I'm not sure that I have time for it

I get the __bionic... failure with VTune 2017u4 on Win7 Pro x64, MSVS 2013

Jim Dempsey

Note, VTune 2017u4 on Win7 Pro x64, MSVS 2013 worked a few times before this showed up.

Jim Dempsey

Hi, I have just downloaded the most recent trial version of Parallel Studio XE. I am also getting the above error message. Has this issue been resolved?
thanks,
Martin

The problem on my system appears to be an interaction with Avast AV. I added an exclusion filter and this fixed the pin issue.

See: https://grid.cs.gsu.edu/~dagarwal2/?q=aggregator

First article.

Jim Dempsey

Posting a link to this notice for everyone's information: https://software.intel.com/en-us/forums/intel-inspector-xe/topic/740105

Please check if your problems are related to the recent PIN issues.

Leave a Comment

Please sign in to add a comment. Not a member? Join today