General failures (including EC 1603) installing

General failures (including EC 1603) installing

I'm just gonna list the general roadblocks that I keep running into trying to get this tool up and running.

1. Downloaded and install INDE hub tool on my laptop, it installed but I didn't know what I needed to do it's just a bunch of squares with download buttons. So I start with compiler, get it downloaded and try to install it, oops it won't completely install without the vs.Android tool installed. Do some research, looks like maybe that comes from the Environment Setup tool, so try downloading and installing that. It wants to install a bunch of Android stuff, looks right, oops one of the packages requires 4GB of memory and I don't have that, guess I can't use this laptop, wish I'd have known that before I spent all this time downloading stuff, did I mention that I have a < 2Mb internet connection. 

2. Try using my work laptop it's got plenty of RAM, download the hub tool, this time I download the Setup Environment widget first. Opps it wants to know where the JDK is, guess I'll have to go install that, download JDK1.7.0_55 install it to c:\java\jdk1.7.0_55 and the jre to c:\java\jre7. Restart the Setup Environment widget and tell it that the JDK is at "c:\java\jdk1.70_55" (I hope that's what it wanted to know). By default it wants to install everything but the 64bit version of the Android NDK, I've got a 64bit system but the defaults are probably correct so I go with it. It starts installing "Component 1 of 9: Android Development Tools (ADT Bundle)", I think it gets through a couple more and I get the dreaded 1603 error in setup_vsPlugin.msi installer (see attached image), guess I'm stuck here too.

3. Lets try a VM, spin up a Win7 IE11 evaluation/test image from MS in VirtualBox. Download INDE hub setup, setup goes OK try to launch it... no dice it just silently crashes. I checked out the windows event log and I see that crashed due to a unhandled System.IO.FileLoadException exception. I tried a bunch of other things like enableing/disabling 3D acceleration, installing VisualStudio, installing JDK, still no dice. 

Furthermore, while I was researching my issues I discovered the thread in this forum that states that only MS Dev Studio 2012 Pro/Ultimate is supported which I don't have. No way am I going to spend close to $500 on an obsolete version of Dev Studio to evaluate this tool. 

What do I do now? 

Matt S. 

Downloadimage/png ErrorCode_1603.png85.66 KB
8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Here are the log files from the c:\user\...\Temp\intel_tmp_mschuckmann




I'm sorry that you've been running into the issues you've described. As you may realize this is a beta release, and we're learning more from customers such as yourself what we need to do to improve the overall usability and robustness of the product. And though the requisites are listed in the FAQ, I'll see if there's more we can do to set proper expectations for installing and using the product. Also, it's not clear that we've tried installing/running INDE from within a VM -- I'll check on this as well to see if your errors are due to limitations of a VM (and if so document these).

Copying the log files really helps, so I'll forward these to the development team for further analysis. As you've probably seen we have a number of instances of the 1603 error, so these log files will be necessary for debugging this.

As to not wanting to spend the money on Visual Studio, I can understand your reluctance to pay money for this tool/version.

Last but not least, it would help if we could get a better idea of what you are trying to use INDE for, as this might help us understand more about what we can do to address your needs.

Again, thanks for using INDE, and I'll try to get some answers back for you.



Thanks for the response Neal, 

First an update on my progress. 

I got past the 1603 error by installing a full copy of Visual Studio 2012 Pro, it's a 90 evaluation version so it's not a permanent solution but I gets things going. That got me through the Environment setup. d.
Next task is to install the compiler, it asks you for the location of the Android NDK I set it to C:\Intel\INDE\Framework\NDK, click next and tells me that the version of the NDK is not supported and that NDK r9 is required, I thought the whole purpose of Environment Setup was to make sure that the correct version of stuff was installed. I looked at C:\Intel\INDE\Framework\NDK\RELEASE.txt and it says r9d. So what's the problem?

The reason I'm evaluating INDE is I'm participating in a research study for Intel to evaluate INDE integration Visual Studio and whom ever setup the study didn't provide much info on exactly what was needed to run the tools or really what to do. 

Matt S.

Attached is the message the compiler installer is giving me when it detects thinks it's the wrong NDK. 

Matt S. 



Downloadimage/png Compiler_NDK_msg.png32.63 KB




Hi Neal,

Any solution to address Matt issue, I've experienced the same problem.




Good news, I've found in an other thread a workaround of this issue...may be it can be help somebody.

Thanks to Colleen,



Colleen Culbertson (Intel) wrote:

There's sort of a workaround for this.  The version of Intel INDE that you have probably gets the r9d but only 14v1 of the ICC.  You need 14v2 of the ICC to recognize r9d correctly. It is available by clicking the evaluate now link (right side) at Be sure to put it exactly where ICC14 v1 had downloaded. Hopefully that will integrate for you.

Leave a Comment

Please sign in to add a comment. Not a member? Join today