FileWriter and Windows 7

FileWriter and Windows 7


I have a strange issue with FileWriter class and Windows 7 Pro. On Windows 7 FileWriter doesn't create the file. On XP everything works fine.

I created a simple code to write a single number to the file but the code doesn't work. No error, but no action.

UMC::FileWriter writer;
UMC::FileWriterParams writerParams;
wcscpy_s(writerParams.m_file_name, _T("C:\\\\foldername\\\\filename.mpg"));

UMC::Status status = writer->Init(&writerParams);
if(status == UMC::UMC_OK)
int i = 5;
int size = 1;

writer.PutData(&i, s);


I traced the UIC sample and found that Init() is using standard CreateFile(...). If I tried to use CreateFile(...) instead of writer->Init(...) it's OK with file creation. I am thinking about some kind of security limitations for Windows 7.

Does anyone know about this problem? I run the system as administrator and Parallel Studio XE 2011 with VS2010 as administrator as well.

Sergey Tsybikov

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi, Intel Support Team:

I figured out what' s going on with UMC::FileWriter on Windows 7

Init() function from audio-video-codecs\core\vm sample works only if I
am using MS Visual Studio debug/release configuration with Multi-Byte
Character Set. If I use Unicode Debug/Release configuration with Unicode
Character Set the above function does nothing even returning the

Does anyone have a suggestion how could I rebuild ipp-samples in unicode under 32-bit Windows?

Sergey Tsybikov
Smith&Nephew Endoscopy

Leave a Comment

Please sign in to add a comment. Not a member? Join today