Segment violation ipp_zlib

Segment violation ipp_zlib

Hi, we are
using ipp_zlib (IPP 6.1 build 137.53) for our project to read/write the PNG
images. Sometimes it produces Segment violation (SIGSEGV) exception by read
image at the point ipp_zlib->inflate on PC with 6 CPUs (Intel Xeon CPU
X5650 @2.67GHz). It could be good reproduce if more than one thread (at least 4
Threads) simultaneous try to read image. Is somebody knows this issue?

17 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Alexey, this is an unknow issue for ipp_zlib.Could you give us the example?--Gennady

Gennady, yes, the attached zip-file contains test.bat file. If you need source i can also upload it. Thank you in advance.

Strange, i could not upload zip file..., now it's Ok. In Test folder is test_ipp_zLib.zip file.

Alexey,

Have you tried the latest version Intel IPP 7.0 and see if this issue is still reproducible?

If you have valid product license, you can go to Intel Registration Center at https://registrationcenter.intel.com to find the latest package, or try the evaluation version at Intel Evaluation Center at http://software.intel.com/en-us/articles/intel-software-evaluation-center/

Thanks,

Ying

Ying,

we have only license for IPP 5 and 6 versions. I will ask our manager to buy a new one.

With old IPP 5.2 version our software is stable.

Alexey,I see no file attached into this thread.Could you please look at this topic "How to attach file to Forum post".--Gennady

Gennady,

Now it should be Ok.

----------------

maybe it will be useful:

0:013> gh
(244.fd0): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
eax=00000001 ebx=00000000 ecx=00000254 edx=0000001f esi=01274fff edi=011cd5b2
eip=009dd897 esp=0139fc7c ebp=011f4f00 iopl=0 nv up ei ng nz na pe cy
cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00010287
*** ERROR: Symbol file could not be found. Defaulted to export symbols for C:\Program Files\MIPS\Ipp-6.1\ippdcp8-6.1.dll -
ippdcp8_6_1!ippsVLCEncodeOne_16s1u+0x35cb:
009dd897 0f6e0e movd mm1,dword ptr [esi] ds:0023:01274fff=????????
0:004> kp
ChildEBP RetAddr
WARNING: Stack unwind information not available. Following frames may be wrong.
0139fcd8 009cfacf ippdcp8_6_1!ippsVLCEncodeOne_16s1u+0x35cb
0139fe5c 10002d26 ippdcp8_6_1!ippsInflate_8u+0xad3
0139feb8 1001531e ImagePNG_6_1!png_read_row(struct png_struct_def * png_ptr = , unsigned char * row = , unsigned char * dsp_row =.......

Gennady,

Do you have any news about this issue?

Alexey,Actually, it seems to us we need more details from you.We tried to check on problem on our side and all works fine with the latest IPP 6.1 update 5 and 6.How long the test should works?on my side,the test was working for 20 minutes on my local Core2Duo and nothing happened...Could you please elaborate more about the System and CPU you are working on?May I ask you to incorporateippsGetLibVersion function into this test and provide the output of this function?--Gennady

Gennady,
It can be happened after 10 Seconds. On my PC with CPU Intel Core i7 4 cores, I could not reproduce it, but our software will be running on target PC with 6 or more CPUs. The test, which has this exception, was reproduced on the Intel Xeon CPU X5650 @ 2.67GHz with 6 cores OS: Winows XP ProfessionalSP 3, and I saw also it on PC with 8 cores.

ippsGetLibVersion:
Name:ippsp8-6.1.dll+

Version:6.1.137.844
Build Date:Jan 23 2010
Version:6.1 build 137.53
Target CPU:p8

ok, thanks for the update. We will check and back to you asap.--Gennady

i was able to reproduce it on my PC in Virtual Mode, pleasesee attached image. In Src.zip is TestIppZLibCon project. Strangely, it still works without exception in original OS!

Attachments: 

AttachmentSize
Downloadimage/png Exception_WinXPMode.png131.79 KB
Downloadapplication/zip Src.zip838.47 KB

As I see you still use IPP 6.1. Is there any chance for you to try the latest version, which is IPP 7.0? There were some bug fixes in data compression samples and functions

Regards,
Vladimir

Vladimir,

For IPP 7.0 result is same, please see attachment.

Attachments: 

AttachmentSize
Downloadimage/png Exception_Ipp70_WinXPMode.png122.84 KB

Hi Alexey

Thanks for your problem you raised.This issue has been submitted to our internal development tracking
database for further investigation, we will inform you once a new update
becomes available.Here is a bug tracking number for your reference: DPD200199464.

Regards, Gennady

Hi Alexey,

IPP 7.0 Update 2 is available now,the issue should be fixed in the vesion. please refer to bleow information to get more information

Version 7.0.2 of the Intel Integrated Performance Primitives (Intel IPP) library is now available. The library is available as astand-alone productor as a component inIntel Parallel Studio 2011,Intel Parallel Studio XE 2011,Intel C++ Studio XE 2011,Intel Composer XE 2011, andIntel C++ Composer XE 2011. Please visit theIntel Software Evaluation Centerto download evaluation versions of these and other Intel software products.

What's New in 7.0.2

  • Additional optimizations for the256-bit Intel AVXSIMD instruction set.
  • FurtherIntel Atom Processor optimizationshave been incorporated.
  • Data compression gains of ~2x via a redesign of the "Inflate for Fixed Huffman" algorithm.
  • Cryptography improvements include 1.4x faster "sign verify" and a 2x faster ippsMontForm() function.
  • The ipp_zlib library is now based on the zlib 1.2.5 distribution.
  • Review a complete listof changes, bug fixes and new features on-line.

--Gennady

Hi Gennady,

Thank you for the update.

Best regards,

Alexey.

Leave a Comment

Please sign in to add a comment. Not a member? Join today