IPP sample (audio-video-codecs) problen

IPP sample (audio-video-codecs) problen

hello:
I run the IPP samples according to the article http://software.intel.com/en-us/articles/performance-tools-for-software-developers-how-do-i-run-the-intel-ipp-samples/ but it turn out mang problems,I use the follow steps,rignt ro not?

first,creating an environment variable;
second,run build32.bat by double click
then the program begin to bulid,but output information tell me that "\core\vm","\io\audio_renders","\io\video_renders" and so on were failed.

Does anyone know the problem,Any help appreciated - sunnymov!

12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Quoting - sunnymov
hello:
I run the IPP samples according to the article http://software.intel.com/en-us/articles/performance-tools-for-software-developers-how-do-i-run-the-intel-ipp-samples/ but it turn out mang problems,I use the follow steps,rignt ro not?

first,creating an environment variable;
second,run build32.bat by double click
then the program begin to bulid,but output information tell me that "corevm","ioaudio_renders","iovideo_renders" and so on were failed.

Does anyone know the problem,Any help appreciated - sunnymov!

What errors are you seeing, and what compiler are you using? You can find more information about the exact errors in the audio-video-codecs_log directory. Also, do you have DirectX installed? It's required for the audio and video renders.

Thanks ,according to what your said,I install the DirectX,and the program now is right.And the simple_player.exe is

created .but how to use the simple_player.exe.I run it in vs2005,there come out a message "NO file to play in

command line" and" Usage: e:w_ipp-samples_p_6.0.0.127ipp-samplesaudio-video-codecs_binWin32de
bug_asciisimple_player.exe
[-s(ilent)]
[-b(lind)]
[-n(atural temp)]
[-u(nrendered audio)
[-d(einterlacing)
[-i
[-t
[-p (must be in quotes if it contains gaps)]
[-v
-in the case of -vfwf>]
[-a
-in the case of -afwf]
[-f]
(-l |stream>(must be in quotes if it contains gaps)"
what are parameters mean,thank!

Quoting - pvonkaenel

What errors are you seeing, and what compiler are you using? You can find more information about the exact errors in the audio-video-codecs_log directory. Also, do you have DirectX installed? It's required for the audio and video renders.

Sorry, I forget to see the file readme.htm,I amso careless.Now,I kown it.Thanks

Hi,
I'm trying to evaluate the IPP's performance when decding H.264, to compare it with Core AVC running off Nvidia's CUDA. I am running IPP 6.0 and when trying to build the sample programs by running build32.bat, got a consistent line of errors, however I have compiled all the codecs and the three software programs manually without any problems in Visual Studio 2005, however I don't seem to be able to get the programs to run.... I want to decode a .mp4 H.264 file and render it to the screen, any help would be much appreciated.

Joe

Joe,

You can try "simpleplayer" application:
>simple_player.exe -vdx yourvideo.mp4

Thanks,
Chao

Quoting - Chao Yu (Intel)

Joe,

You can try "simpleplayer" application:
>simple_player.exe -vdx yourvideo.mp4

Thanks,
Chao

C:Program FilesIntelIPP6.0.0.062ia32ipp-samplesaudio-video-codecs_binWi
n32release>simple_player.exe -vdx c:Final_Sequence_480_25.avi
Usage: ????????e????????????????i
[-s(ilent)]
[-b(lind)]
[-n(atural temp)]
[-u(nrendered audio)
[-d(einterlacing)
[-i
[-t
[-p (must be in quotes if it contains gaps)]
[-v
-in the case of -vfwf>]
[-a
-in the case of -afwf]
[-f]
(-l |stream>(must be in quotes if it contains gaps)

What am I doing wrong??

It looks that the application prints out invalid character
"Usage: ????????e????????????????"

Can you try to use "ascii" configuration to build the sample code in the VC projects choose
release_ascii, or debug_ascii

Check how it works

Thanks,
Chao

Quoting - Chao Y (Intel)


It looks that the application prints out invalid character
"Usage: ????????e????????????????"

Can you try to use "ascii" configuration to build the sample code in the VC projects choose
release_ascii, or debug_ascii

Check how it works

Thanks,
Chao

Chao,
Many thanks for help, the ASCII release does solve that problem, but how do I render the file to the screen??
Whats the differnce between the different -v settings -v??

"C:Program FilesIntelIPP6.0.0.062ia32ipp-samplesaudio-video-codecs_binWi
n32release_ascii>simple_player.exe -vdx c:Final_Sequence_480_25.avi

Stream Type : AVI"

Joe

Quoting - yosepho

Chao,
Many thanks for help, the ASCII release does solve that problem, but how do I render the file to the screen??
Whats the differnce between the different -v settings -v??

"C:Program FilesIntelIPP6.0.0.062ia32ipp-samplesaudio-video-codecs_binWi
n32release_ascii>simple_player.exe -vdx c:Final_Sequence_480_25.avi

Stream Type : AVI"

Joe

The -v flag identifies how to render to the screen. Under windows your best bet is -vdx since that will use DirectShow to display.

Quoting - pvonkaenel

The -v flag identifies how to render to the screen. Under windows your best bet is -vdx since that will use DirectShow to display.

Many thanks, its working now..
Just out of curiosity what do the other rendering options stand for??

Joe

BLT and GDI are readers supported in old sample code. UMC sample code in IPP 6.1 removed these renders:
http://software.intel.com/en-us/articles/blt-and-gdi-render-removed-in-ipp-61-umc-sample-code/

Thanks,
Chao

Leave a Comment

Please sign in to add a comment. Not a member? Join today