h.264 stream decoding problem

h.264 stream decoding problem

IPP h264 decoder doesn't return decompressed image from the queue
returns UMC_ERR_NOT_ENOUGH_DATA instead
VideoLANs VLC decompresses it successfully

AttachmentSize
Downloadapplication/octet-stream EverFocus-1.264693.05 KB
6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Here is the file grabbed from IP camera

Quoting - jslav
Here is the file grabbed from IP camera

Depending on what your code looks like, you might need to loop over the decode. If you have not tried it yet, load the file into the simple_player application. I always use that application for initial testing since it seems to be fairly compelete.

There is a good sample H.264 decode loop at the following link:

http://software.intel.com/en-us/articles/getting-started-with-intel-ipp-...

Peter

Quoting - pvonkaenel

Depending on what your code looks like, you might need to loop over the decode. If you have not tried it yet, load the file into the simple_player application. I always use that application for initial testing since it seems to be fairly compelete.

There is a good sample H.264 decode loop at the following link:

http://software.intel.com/en-us/articles/getting-started-with-intel-ipp-...

Peter

Thank you for advice.

Quoting - jslav

Thank you for advice.

Finally, I fixed my problem. It was the bug in my code of stream initialization method.
Thank a lot for reference.

Had a similar problem with the live RTSP/RTP stream - finally got it working, but with resolutions bigger than CIF the decoder gives me UMC_ERR_NOT_ENOUGH_DATA for the *regular* GetFrame and UMC_ERR_INVALID_STREAM for the GetFrame with NULL for the in parameter...my packetization-mode = 1 and all NALUs are of types 5 and 1, and i feed them one-by-one...

could anybody suggest where to look for insight?

thank you,
Oleg

Leave a Comment

Please sign in to add a comment. Not a member? Join today