failed to compile umc_pipeline

failed to compile umc_pipeline

hi all,

Icompiled umc_pipeline and it failed, the log is

NMAKE : fatal error U1077: '"C:Program FilesMicrosoft Visual Studio 8VCBINcl.exe"' :

What's wrong with it, please tell me, Thanks!


15 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


that message actually does not contain any useful information except that it indicate that you have some issue compiling some file.

Did you try to build IPP media sample with build scripts? Any issues with that? If you have no issues compiling IPP media sample as is, you can take a look on build log files to understand what options you might need in your self-maded VC8 studio project to get it compiled.


hi, Vladimir

I have already resolved this problem. It's my compile environment wrong. Sorry, it wastes your time. Thanks a lot!

Hi, i'm hyeran.

I have same problem that is "failed to compile the umc_pipeline"

because of that, I couldn't compile Codec...(codec part use the umc_pipeline, doesn't it?)

So, How can you solve this problem?

please Help me~!!

Correct me if I am wrong. I think umc_pipeline is only used by applications, such as simple_player. So it is on top of codecs and below applications:

codecs, renders

You may need compilation of both codecs and renders before you can compile umc_pipeline, and renders may require pre-installation of DirectX SDK.

i'm sorry but i can't understand well...

i compile using the build32.bat. (didn't any work).

during the executing build32.bat, the umc_pipeline , vm_pluse & audio_codec & all application. are fail.

So, I couldn't using those libs

Help me.....please~!

You may check log files at folder


to see what causes the compiling failure.

make sure vm_plus & audio_codec are compiled before you look into umc_pipeline.

several weeks ago, I failed to compile because I installedvc++6, vc++7 and vc++8 in my os. I uninstalled vc++6 and vc++8, used vc++7 to compile the sample, it's ok.

You can set compiler option when run build32 (or so):
Usage: build32.bat {cl7/cl8/icl9/icl91}

So it is ok to have multiple compilers on same system.

But if you are using VC compiler, you may need(?) run vcvars32.bat to set environment for that compiler before you run build32, which is located at:

Microsoft Visual Studio 8VCin

Microsoft Visual Studio .NET 2003Vc7in

Dear kantonwang,

I have same problem and have spent quite a lot of time for that.

Could you please help me out as to how you solved it?

Best Regards,


I also have a problem with compiling umc_pipeline. I use the build32.bat script in ipp-samplesaudio-video-codecs and I have tried to compile with both Microsoft and Intel compilers. Looking att the logs I get the following error messages:


NMAKE : fatal error U1077: '"C:Program FilesIntelCompilerC++10.0.025Ia32Binicl.exe"' : return code '0x2'


NMAKE : fatal error U1077: '"C:Program FilesMicrosoft Visual Studio 8VCBINcl.exe"' : return code '0x2'

I have installed the DirectX SDK (August 2007). I also tried the (December 2005) version since that was a requirement according to audio-video-codecsapplicationumc_h264_dec_con
eadme.htm, but neither of them works. I can compile some of the code but not the H.264 decoder and that is what I am most interested in.

What can be the problem?

Information you provided is not enough to answer your question. From your log it is not clear compilation of which source file failed and why.



I have the exact same problem and I believe it has something to do with an incompatibility between DirectX ***and*** the build script. Does anyone know the solution? I have hacked the build script already and I do not want to keep on hacking this just to get it to build. For some reason, LPDIRECTSOUND8 is trying to be loaded by the Intel IPP file dsound_buf.h and this is causing the build error? I do not really know DirectX too well but the Intel IPP is referencing a data structure (LPDIRECTSOUND8) that is either deprecated or just does not exist in the August 2007 SDK distribution.

Thank you,


I forgot to mention that this happens when I try to build audio-video-codecspipelineumc_pipeline when I am trying to build the sample application simple_player.


Hi Adam,

that should be fixed in our the last version, IPP 5.3 update 2. Could you please check with the latest version?


Leave a Comment

Please sign in to add a comment. Not a member? Join today