Problems with the H.264-encoder

Problems with the H.264-encoder

Hi,

I am currently trying to get the H.264-encoder to work. The compilation went fine but the problem occurs with the encoded movie. I use an yuv-file which has successfully been used with the MPEG2-encoder where I have tried to match the .par file for the H.264-encoder. Below is the .par-file used for the MPEG2-encoder and then the .par-file I have used for the H.264-encoder. I have no idea what is going wrong, can someone please help me.

Thanks in advance
/Mathias

MPEG2:
CommentLine: MPEG-2 Sequence.
foreman_cif.yuv /* name of source files */
- /* name of intra quant matrix file ("-": default matrix) */
- /* name of non intra quant matrix file ("-": default matrix) */
90 /* number of frames */
20 /* N (# of frames in GOP) */
2 /* M (I/P frame distance) */
352 /* horizontal_size */
288 /* vertical_size */
1 /* aspect_ratio_information 1=square pel, 2=4:3, 3=16:9, 4=2.11:1 */
10 14 20 /* q_scale (I P B) */
352 /* display_horizontal_size */
288 /* display_vertical_size */
0 0 0 /* frame_pred_frame_dct (I P B) */
2 2 10 10 /* P: forw_hor_f_code forw_vert_f_code search_width/height */
2 2 10 10 /* B1: forw_hor_f_code forw_vert_f_code search_width/height */
2 2 10 10 /* B1: back_hor_f_code back_vert_f_code search_width/height */

H.264:
H264 Sequence.
foreman_cif.yuv /* name of source files */
90 /* number of frames */
1 20 /* 1(reserved) , N (# of frames in between I frames) */
2 /* Number of B frames between I (or P) and next P */
352 /* horizontal_size */
288 /* vertical_size */
10 /* frame_rate_code */
0 10 26 26 300000 /* method(0 - quant_codes, 1 - CBR, quant_codes (I P B) & bitrate !!!ALL must be specified */
1 4 4 0 /* extra block split, search x,search_y, implicit weighted biprediction(reserved)*/
352 /* display_horizontal_size */
288 /* display_vertical_size */
0 sample.log /* log mask and template filename of log-file (0 and "any value" for none) (not implemented yet)*/

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi,

it is a bit unclear what the problem you have.I have to say that there is some assimetry between our H.264 encoder and H.264 decoder samples. Our H.264 encoder do support JM7.3 while our H.264 decoder supports only JM6.1. Sorry for that inconvenience. You should contact with technical support, probably they can provide you update for this sample.

Regards,
Vladimir

We make some updated on H.264 coding samples, please try download video samples again to get the updated samples for H.264.

Thanks,
Ying S
Intel IPP Support

Leave a Comment

Please sign in to add a comment. Not a member? Join today