_dl_catch_error (problem with new kernel/gcc?)

_dl_catch_error (problem with new kernel/gcc?)


I used the ipp30 on a mandrake linux with kernel version 2.4.35 and gcc 3.2.2 and everything worked fine. Now our systems were updated to a mandrake linux with kernel 2.6.8 and gcc 3.4.1. When I try to compile my sources on the new system I always get a linker error:

/ipp/sharedlib/libipps.so: undefined reference to `_dl_catch_error'

Trying to start a program that was compiled on the old system, i get a similar error:

./test1.td: symbol lookup error:

/ipp/sharedlib/libipps.so: undefined symbol: _dl_catch_error

I also did some test with ipp40, but always got the same results...

Any ideas or suggestions?

cheers, Flo

8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


you are right, unfortunately, there was a problems in IPP on linux with kernel version 2.6. This problem will be fixed in the next version of IPP which is coming soon.


By "Next Release", did you mean 4.1, or a release after 4.1? That is, does 4.1 work with the 2.6 kernel?

I'll verify that and give you update soon


That's right, IPP should support Linux kernel 2.6



I'm in the same situation, running my already compiled application in a freshly installed linux machine, with kernel in it.

I'm getting basically the same error message:

/mydir/myapp: symbol lookup error: /usr/lib/libippi.so: undefined symbol: _dl_catch_error

Is there any way to trace/solve this problem? I'm using IPP 4.1 .




could you please provide more details about your issue?
like, what Linux distribution do you use, what processor do you have, do you use IPP v4.1 release or beta version?


OK, it was my mistake, sorry. My target system still had the old ipp libraries. I replaced them with 4.1 and now it works just fine.

Thanks anyways,


Leave a Comment

Please sign in to add a comment. Not a member? Join today