Celeron and IPP example... help.

Celeron and IPP example... help.

Pleasecompile and run the following single file project on Celeron Processor and let me know what results you get. My Celeron 2.4 gives me NO SPEED GAIN AT ALL. Please help.

// --- Intel Performance Primitives test --- //

#define inner 1280 /* Feel free to experiment with these values */
#define outter 10000000

int main(int argc, char *argv[])
int i,j;
float p[inner],q[inner],x1,x2;
unsigned long BeginTime1,EndTime1;
unsigned long BeginTime2,EndTime2;


/* Initialize: */

BeginTime1 = GetTickCount(); /* ~10 ms timer resolution */

x1 += p[i]*q[i]; /* ... the usual, slow way. */
EndTime1 = GetTickCount();

BeginTime2 = GetTickCount(); /* ~10 ms timer resolution */

/* Nested loops, inside loop performs dot product which is in fact:
x = p0*q0 + p1*q1 + p2*q2 + ... +pn*qn */
ippsDotProd_32f( p,q,inner,&x2 );/* Intel optimized... */
EndTime2 = GetTickCount();


Miliseconds NORM: %d.
printf(" Miliseconds IPP: %d.
(Dot product result: x1 = %f)",x1);
(Dot product result: x2 = %f)

return 0;

14 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


Dear Customer,
What is your output on this system?Did you test this code on any other systems and what are the other results? Which version of IPP are you using?

By the way, have you also submitted this question into Intel Premier Support at https://premier.intel.com to report this problem? If not, I would encourage you to do so. So our IPP support staff will provide assistance on this issue.


System: Win XP sp1a
IPP: 4.0
Ccompiler: ICC 8.0 or MS (close results)

Results for source cod given above:

1.) OnIntel Celeron - 2.4 GHz:

Miliseconds NORM: 32875

Miliseconds IPP: 32859

2.) On Intel Pentium 4 - 1.6 GHz:

Miliseconds NORM: 40900

Miliseconds IPP: 7100

I can't go http://premier.intel.com because I am still using trial version of IPP and C compiler. How can I bye IPP if I am not sure it is working on Celeron?

Ysong please help or forward this to someone at Intel labs who can compile the example. Thank you...

I have just seen that I am eligable to get help from premier.intel.com even though I am using IPP trial version.Did not pay attention to what registration email said, sorry. Now the problem is that premier.intel.com is not working (the page cannot be displayed)...


could you please also to print out the library version info? Please embedpiece of code like this into your program and give us the results:

#include "ippcore.h"

static void ipps_version(void)
int freq;
const IppLibraryVersion* version;

version = ippsGetLibVersion();

printf("IntelippSP library, version:
printf("major: %d
printf("minor: %d
printf("majorBuild: %d
printf("build: %d

printf("target CPU is <%c%c%c%c>

printf("Name: %s
printf("Version: %s
printf("BuildDate: %s

printf("Detected CPU type: %d

printf("Detected CPU freq: %d

} /* ipps_version() */

The reason I'm asking that is the different Celeron processors has different processor core, some of the has Pentium 3 core but another has Pentium 4 core.


Here is what it says:

Intel ippSP library, version:
major: 4
minor: 0
majorBuild: 19
build: 77
targer CPU is
Name: ippspx.dll
BuildDate: Oct 16 2003
Detected CPU type: 6
Detected CPU freq: 2395

why is it running a px.dll library version, which is an optimizedgeneric c code? celeron 2.4 GHz is still pentium 4 so it should be w7.dll.

detected cpu type is ok (6=ippCpuP4=Pentium 4 processor ):

typedef enum {
/* Enumeration: Processor: */
ippCpuUnknown = 0x0,
ippCpuPP, /* Intel Pentium processor */
ippCpuPMX, /* Pentium processor with MMX technology */
ippCpuPPR, /* Pentium Pro processor */
ippCpuPII, /* Pentium II processor */
ippCpuPIII, /* Pentium III processor */
ippCpuP4, /* Pentium 4 processor */
ippCpuP4HT, /* Pentium 4 Processor with HT Technology */
ippCpuCentrino, /* Intel Centrino mobile technology */
ippCpuITP = 0x10, /* Intel Itanium processor */
ippCpuITP2 /* Itanium 2 processor */
} IppCpuType;

Message Edited by dand123 on 01-09-2004 09:05 AM

And you haveippw7.dll accessible, under ipp20 folder, right? Please be sure that there is no other version of IPP in PATH before IPPv4.0 beta.

By the way, we will try to investigate this. Unfortunately I have no Celeron based system close to me, so it will take some time.


I did have some bad PATH enties left from the IPP 3.0. I have removed them or changed to paths for IPP 4.0, but the problem is not solved. Still using px versions of dlls...

Consider this:

IppStatus sts;

sts = ippStaticInitCpu(ippCpuP4);


sts = ippStaticInitBest();


Both of the functions above return 24 which is ippStsNoOperationInDll which is explained as"The function does nothing in the dynamic version of the library."

How do I force my program to load w7.dll?

Message Edited by dand123 on 01-10-2004 04:55 AM

Functions ippStaticInit, ippStaticInitCpu, ippStaticInitBest are serve for initialization of static libraries. If you are linked with DLLs they will do nothing. Please read IPP documentation.

To use DLL you need to place IPP dispatcher (ipps20.dll) at the same folder as your executable and create here subfolder ipp20 and place ippsw7.dll to this subfolder.

There is no way to force dispatcher to load a particular DLL. You can control optimized code only in static merged libraries through function ippStaticInitCpu.

I managed to link staticaly with w7 library by including ipp*merged.lib, so for now I will stick to that temporary solution. I hope intel premier support will have the answer ready in the near future... Thanks for your help.

Intel Premier Support has solved this issue, it turned out that user's system had incorrect path for IPP 40. After reinstalling the Intel IPP runtime installer, it is fixed, and can detect ipp*w7 version correctly.

Intel IPP

In fact,
it turned out that the user (myself) has had an AMD processorsystem when installed IPP 4.0 Runtime. After that, thesystem waschanged to Intel (new processor, new motherboard, WinXP repair), but IPP's stayed the same (AMD version!). IPP Runtime reinstallation solved the problem (after manually removing the old dlls from windowssystem32ipp20).

Leave a Comment

Please sign in to add a comment. Not a member? Join today