Building IPP Samples - CMake issue

Building IPP Samples - CMake issue

Hi, 

I'm trying to build the IPP Samples, with command 

perl build.pl --cmake=speech-codecs,ia32,make,s,st,debug --build --comp=intel

and am getting some cmake errors. 

Currently running on Debian (kernel 2.6.32) with CMake 2.8.10.1. 

Console output is attached. Has anyone had any CMake errors like this?

Brian

AttachmentSize
Downloadtext/plain cmake-output.txt1.92 KB
5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

>>I'm trying to build the IPP Samples... ...on Debian (kernel 2.6.32) with CMake 2.8.10.1...
>>...
>>CMake Error: Could not open file for write in copy operation /CMakeCCompiler.cmake.tmp
>>CMake Error: : System Error: Permission denied
>>...

This is access rights related issue on your computer and it is not related to IPP.

>>CMake Error at /usr/share/cmake-2.8/Modules/CMakeTestCCompiler.cmake:36 (TRY_COMPILE):
>> Unknown extension ".c" for file
>>
>> /media/shared/ipp_samples/ipp-samples.7.1.1.013/__cmake/speech-codecs.
>>ia32.make.s.st.debug/CMakeFiles/CMakeTmp/testCCompiler.c
>>
>> try_compile() works only for enabled languages. Currently these are:
>>
>> C CXX

There is a strange contrudiction since 'testCCompiler.c' is the C-language file. Could you check a line 36 in the 'cmake' file?

Quote:

Sergey Kostrov wrote:

>>CMake Error at /usr/share/cmake-2.8/Modules/CMakeTestCCompiler.cmake:36 (TRY_COMPILE):
>> Unknown extension ".c" for file
>>
>> /media/shared/ipp_samples/ipp-samples.7.1.1.013/__cmake/speech-codecs.ia32.make.s.st.debug/CMakeFiles/CMakeTmp/testCCompiler.c
>>
>> try_compile() works only for enabled languages. Currently these are:
>>
>> C CXX

There is a strange contrudiction since 'testCCompiler.c' is the C-language file. Could you check a line 36 in the 'cmake' file?

Hi Sergey,

I have just (in the last hour) solved this issue. The first issue was user rights as you pointed out. Then I solved the cmake issues but completely uninstalling cmake from my system, then building and installing the latest cmake source.

I am now in the process of trying to build the usc_speech_codec binary with static linking...

Hi,

>>I have just (in the last hour) solved this issue. The first issue was user rights as you pointed out. Then I solved the cmake issues but
>>completely uninstalling cmake from my system, then building and installing the latest cmake source.

Thanks for the update.

Leave a Comment

Please sign in to add a comment. Not a member? Join today