IPP installation problem

IPP installation problem

I tried to install the IPP in my PC(UBUNTU),but it is asking for activation code for evaluation version also.

can you pls suggest any solution?

can you please suggest ,How can i integrate G729 codec with PJSIP?

10 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

have the serial number we have sent you helped with this problem?

Thanks for your help Gennady,my problem got solved.

can you please provide the link form where i can download IPP samples?

Is there any document expalining how to build the IPP samples?

Hello lenin,

IPP samples you can find at the same page where IPP binaries are located. As an example, You will see Related Files fol Linux:
get-crypto-library.htm   (Release Notes)8 KBl_ccompxe_gen_ipp_7.1.1.117.tgz   (ReadMe | Release Notes)86 MBl_ipp-samples_p_7.1.1.013.tgz   (ReadMe | Release Notes)7 MBl_ipp-samples-binary_p_7.1.1.013.tgz   (ReadMe | Release Notes) and etc for 

here is the link: https://registrationcenter.intel.com/RegCenter/Download.aspx?productid=1621

the description about how to build - you can find into each samples.


Hi Gennady,

Thanks for the reply.

Itried to build the samples by following the document in samples folder.

{Running Intel® IPP Samples on Linux*

Make sure the Intel® IPP is installed correctly and LD_LIBRARY_PATH environment variable contains path to the Intel® IPP binary before executing the sample. This can be done with

source /opt/intel/ipp/bin/ippvars.sh [intel64|ia32]  }

But when i give this command it is giving an error.

even when i run the perl build.pl --cmake=SAMPLE,ARCH,GENERATOR,LINKAGE,THREADING,CONFIG

it is giving an error:cmake command not found.

can you please give any suggestion or any link for building the samples.



Hi Lenin,

You need to install CMake open-source build system from http://www.cmake.org for that.


Thanks for the reply sergey.

I have downloaded cmake package as suggested,but while running configure iam getting this error,

xxx@xxx-desktop:~/integ-PJSIP$ export IPPROOT=/home/lenin/l_ipp_7.1.1.117_ia32/
xxx@xxx-desktop:~/integ-PJSIP$ export IPPSAMPLES=/home/lenin/ipp-samples.
xxx@xxx-desktop:~/integ-PJSIP$ ./configure --enable-ipp --with-ipp=$IPPROOT --with-ipp-samples=$IPPSAMPLES
bash: ./configure: No such file or directory

can you pls suggest any solution?

I am following this link:http://trac.pjsip.org/repos/wiki/Intel_IPP_Codecs

and the document in folder : ipp-samples.



Hi sergey,


If yes,can you pls send me the quotation of pricing to buy it.

I want to integrate G729 codec with the pjsip for ARM 9 platform in linux.


lenin t. wrote:

I am following this link:http://trac.pjsip.org/repos/wiki/Intel_IPP_Codecs

Hi Lenin,

This page is dreadfully outdated:)). To build speech codecs in 7.1.x you should use only "build.pl" script with command line like

  $ perl build.pl --cmake=speech-codecs,ia32,make,s,st,release --clean --build

which will build codec libraries and sample speech applications on IA-32 with static single-thread IPP libraries. Build procedure is described in "Installation and Build" chapter of "documentation/ipp-samples.html".

Regarding your second question about ARM for speech codecs, I would say "no". If you even be able to compile codecs, which are in source code form, you will see that they call IPP functions from binary IPP libraries. We have IPP libs for Intel architectures only.


Hi Lenin,

You may be able to compile speech codec source files using ARM compiler (or course, we never tried), but they call binary IPP functions from the libs, which are Intel(R) architecture-oriented only. So, there is no way to get it working on ARM.

Regarding build problems, the web-page, you provided, is dramatically outdated and refers to IPP 5.3. To build speech codecs you must use command line described in "Installation and Build" section of "ipp-samples.htm" document. It must be something like

  $ perl build.pl --cmake=speech-codecs,ia32,make,s,st,release --clean --build


Leave a Comment

Please sign in to add a comment. Not a member? Join today