cmake error for ipp-sample.

cmake error for ipp-sample.


I followed exactly how to setup the Main Samples. (w_ipp-samples_p_7.1.1.013)

I installed perl and cmake properly, as instruced.

And, when I typed  "perl", I got the follwoing, which is all okay so far:

Usage: perl --cmake=SAMPLE,ARCH,GENERATOR,LINKAGE,THREADING,CONFIG [--clean] [--build] [--msdk] [--comp=native/intel]
Required variants:
advanced-usage | | | | |
audio-video-codecs | | | | |
computer-vision | | vc2012 | | |
data-compression | | vc2010 | | |
image-codecs | | vc2008 | | |
image-processing | ia32 | nmake | s =static | st =single | debug
language-interface | intel64 | make | d =dynamic | mt =multi | release
signal-processing | | eclipse | | |
speech-codecs | | xcode | | |
string-processing | | | | |
uic | | | | |

Optional flags:

--clean - clean build directory before projects generation / build
--build - try to build projects before generation
--comp - try to use custom compiler, native(=gcc/cl.exe) or intel(=icc/icl.exe). Need to call environment!


perl --cmake=audio-video-codecs,ia32,vc2010,s,st,release [ only generate projects ]
perl --cmake=uic,intel64,make,s,mt,debug --build [ generate and then build ]
perl --cmake=uic,intel64,make,d,mt,debug --build --clean [ generate, clean and build ]

But, when I tried to generate any of the projects, it keeps failing. And, no matter what <SAMPLE> I try, it fails.

for example, when I tried to build with UIC (just like below), I keep getting the following error:

C:\Program Files (x86)\Intel\Composer XE 2013\ipp\ipp-samples.\builder>perl --cmake=uic,intel64,vc2010,d,mt,debug

Not searching for unused variables given on the command line.
CMake Error: The source directory "C:/Program Files (x86)/Intel/Composer XE 2013/ipp/ipp-samples." does not exist.
Specify --help for usage, or press the help button on the CMake GUI.

I am not sure why it is looking for such directory. I am not sure, but somehow it looks for a directly that doesn't exist.

Any idea what is going on? 

Many thanks in advance, 


5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

in that case: do you see really the UIC sample installed on your system?

It is not just UIC. I get the same error message with other samples too (e.g audio-video-codecs, ...). 

I have a feeling something is not right with Cmake? Do i need anything else too run the Cmake? (e.g. maybe "make", or something else?)


I think, you need to move the samples out of "Program Files". First, because if it's Windows 7, writing to "Program Files" requires elevated permissions. Second, build script fails on directories with spaces in the name. We must have fixed this, but I don't remember if this fix was released or not. So, better not to experiment. Move the samples directory to plain "C:\work" or so.



that solved it....

cmake didn't like directories with spaces....


Leave a Comment

Please sign in to add a comment. Not a member? Join today