Can't build UIC samples

Can't build UIC samples

Hi all!

I downloaded IPP samples from Intel web page for IPP 7.1. I also installed CMake and Active Perl 5.16. I tried to build samples in accordance  with guide from Intel. I also set path to *.h and *.lib of IPP in PATH variable. But when I tried to start build (perl --cmake=uic,ia32,vc2010,d,mt,release), I got an error message : "Intel(R) IPP was not found".

May be build procedure requires some additional settings?

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

>>...I got an error message : "Intel(R) IPP was not found".

Please take a look at a script and find a code that shows that message. In that case you will see the root case of the configuration problem.

Hi Roman,

*.h and *.lib are not a matter of PATH variable. You need to properly set IPPROOT. It must point to folder where IPP's [include] and [lib] folders are. For example, ipp.h file will be searched in $IPPROOT/include path. If you have Intel Composer or Parallel Studio, start command line prompt window from <Start>/All Programs/Intel Composer.../Command Prompt/...

Or, start cmd window and execute ippvars_ia32.bat (ippvars_intel64.bat) from IPP bin folder. It also sets IPPROOT.


Hi Sergey,

After manual setting of IPPROOT variable (ippvars_ia32.bat doesn't make anything on Windows 7 32) the generation of VS2010 source code was completed successfully. uic_transcoder_con works perfectly.

Thank you very much!!!

Best regards,


Leave a Comment

Please sign in to add a comment. Not a member? Join today