ippiResizeCubic_8u_C3R crashes...

ippiResizeCubic_8u_C3R crashes...

I tried using the sample code from the IPP website for resizing an image.  In my case, I created an empty 4800x4800 pixel image and tried to make a new copy of the exact same size.  I know, crazy, but it demonstrates the error.  Here is my sample code that I used to call the function:

    // CODE TO TEST INTEL IPP RESIZE CODE
    Ipp32s srcStep;
    Ipp8u* pSrc = ippiMalloc_8u_C3(4800, 4800, &srcStep);
    IppiSize srcTileSize = { 100, 4800 };
    Ipp32s dstStep;
    Ipp8u* pDst = ippiMalloc_8u_C3(4800, 4800, &dstStep);
    IppiSize dstTileSize = { 100, 4800 };
    Ipp32s xNumTiles = 1;
    Ipp32s yNumTiles = 48;

 
    return(separateTileResizeExample_C3R(pSrc, srcTileSize, srcStep, pDst, dstTileSize, dstStep, xNumTiles, yNumTiles));

 

The function call that I'm referring to is the one on Intel's developer site:

http://software.intel.com/sites/products/documentation/doclib/ipp_sa/80/...

and the exact line of code causing the crash is:

status = ippiResizeLanczos_8u_C3R(pSrcT, srcStep, pDstT, dstStep, dstOffsetZero, dstTileSize, borderT, 0, pSpec, pBuffer);
2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Never mind this demo code.  I found the error above that was causing the crash.  So I need a new test case that recreates the actual error I am getting.  I will post that shortly as soon as I have a test case the creates the error.

Leave a Comment

Please sign in to add a comment. Not a member? Join today