No DLL was found in the Waterfall - Error

No DLL was found in the Waterfall - Error

Hi everybody,

I'm not sure if this is the right forum to ask, please move if there is a better place to ask this qustion.

I'm heaving trouble with the "Integrated Performance Primitives" library. A custom application throws the "No DLL was found in the Waterfall procedure." error message. Since this only happens on some Workstations (mine, in particular :-) ) it could be that it depends on the hardware configuration (CPU) of the system? I'm running a Intel(R) Xeon(R) CPU E5-1620.

I already found a page here giving advice how to get rid here (Intel® Integrated Performance Primitives (Intel® IPP) - Error:), but even after adding the path to the lokal ippi20.dll/ippiw7.dll to the environmental variables the error still appears. I also tried registering both the ippi20.dll and ippiw7.dll via regsrv32.exe, which results in an error stating "The module 'ippi20.dll' was loaded, but the entry-point DllRegisterServer was not found."

I'd highly appreciate any ideas of how to get rid of the error.

Thanks a lot in advance,

Ferdinand

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

ippi20.dll !  what version of IPP you are using? it seems like version 4.1? 

 

Hi,

thank you for the quick answer!

It's a third party piece of software throwing the error, so I don't know. I just get the error message and after some research figured out it had to do with the Intel Integrated Performance Primitives. So I searched the programm folder and stumbled upon ippi20.dll and ippiw7.dll. Is there anythin I could do without having access to the source code?

are you sure your application is 32 bit and you added path to the 32bit dll?

Hi Ferdinand,

could you perform a search of ascii string in ippiw7.dll like "ippiw7.dll  v4.0    Oct 14 2003" - it is better to use "ippiw7" as a pattern - the string you'll look for will not be the first one with this pattern, but in order to try to help you we need to know the particular IPP version that is used in this app.

regards, Igor

Hello Gennady and Igor,

thanks for your suggestions. I figured out the issues I had with the software. The PC I'm working on already had a Version of the "ippi20.dll" in System32, which the application was using. Unfortunately, there was a hard coded relative path to "ippiw7.dll", that obviously could not be found... I'm now using the "right" ippi20.dll and the software works just fine.

Thanks again for your support,

Ferdinand

Good to know that everything is OK now... And interesting to know that more than 10-years old libraries are still used.

Regards, Igor

Leave a Comment

Please sign in to add a comment. Not a member? Join today