IPP 8.1 H264 performance

IPP 8.1 H264 performance

Hi,
I downloaded 30-days evaluation version of IPP 8 and compiled video-encoder: umc_video_enc_con.
Encoding speed for h264 looks too slow, compare to mpeg2:
mpeg2 - 200 fps, mpeg4 - 130 fps, vc1 - 40 fps, h264 - 30 fps

QUESTION: Is it a limitation of demo-version, bug or feature?

Below is output screen of console application:

umc_video_enc_con.exe d:encoder.cfg -c h264 -t 2 -r 720 480 -b 1800000 -i ice_720x480.yv12 -o ipp.h264
Intel(R) IPP:
ippCore 8.0.0 (r40040) May 22 2013
ippSP SSE4.1/4.2 (p8)+ 8.0.0 (r40040) May 22 2013
ippIP SSE4.1/4.2 (p8)+ 8.0.0 (r40040) May 22 2013
ippVC SSE4.1/4.2 (p8)+ 8.0.0 (r40040) May 22 2013
ippCV SSE4.1/4.2 (p8)+ 8.0.0 (r40040) May 22 2013
ippCC SSE4.1/4.2 (p8)+ 8.0.0 (r40040) May 22 2013

Input file name: ice_720x480.yv12
Output file name: ipp.h264

Input data: YUV420 (8,8,8) PROG. 720x480 (1:1)
Output stream: H264 YUV420 (8,8,8) PROG. 720x480 (1:1) 30.00fps 1800000bps P100 L30

Progress: 100.00%; Frames: 2013; FPS: 34.13

Statistic (2013 frames):
Overall: 68.53 sec; 29.37 fps
Encoding: 67.65 sec; 29.76 fps
Conversion: 0.17 sec; 11821.75 fps

Encoded size: 15207050 bytes
Compression ratio: 68.62
Encoded/expected: 1.01

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hello,  This is an expected behavior for h264 encoder. There are no limitation for evaluation version compare with commercial one. Please pay attention to this article describing legacy policy for this example follow the link: http://software.intel.com/en-us/forums/topic/401253

thanks

 

Hi Ivan,

Another point is, that H.264 codec in UIC is parallelized with OpenMP. Could you try to build it multi-threaded? For that you need to enable OpenMP in h64_enc project.

Regards,
Sergey

Yes, I recompiled whole sources with "USE_OPENMP" (this need to add libiompstubs5md.lib)
Encoding speed is the same 8-(
I tried with different command-line options: -t,  --ipp_cpu, --ipp_threads
Looks like the only one CPU core is running: UPU usage is 50-60% always

Thanks

Hi, Ivan!

You are not the first developer who has problem with H264 encoding via UIC.

As it was said previously UIC - deprecated.

But I noticed inside this forum at least one success implementation of H264 encoding via Intel Media SDK.

Media SDK is free of charge now and it has full support of intel.

 

Best regards,

Roman

>>>Looks like the only one CPU core is running: UPU usage is 50-60% always>>>

Can you check with Process Explorer how many threads were created?

Leave a Comment

Please sign in to add a comment. Not a member? Join today