IPP 8.1 and OpenCV 2.4.9

IPP 8.1 and OpenCV 2.4.9

Hi folks,

I tried to rebuild OpenCV 2.4.9 in a way that it automatically uses IPP 8.1. The documention on how to do this seem to be very outdated and doesn't work anymore with the latest versions of these libraries.

It would be great to have a step-by-step tutorial on how to get this to run. In my case I am interested in building it for Windows 8.1, 64-bit release using Visual Studio 2013.

I tried various things mixed from old tutorials on the web. The function to test if IPP is active did only return "1" optimized/uploaded funtion instead of 140+ when IPP is active.


int NumUploadedFunction = 0;

NumUploadedFunction = cvUseOptimized(1);

printf("\t NumUploadedFunction = %d \n\n", NumUploadedFunction);

const char* opencv_lib = 0;

const char* add_modules = 0;

cvGetModuleInfo(0, &opencv_lib, &add_modules);

printf("\t opencv_lib = %s,\n\t add_modules = %s\n\n", opencv_lib, add_modules);



2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

First at all, build of OpenCV from source code in MS Visual Studio is not a trivial task (even without IPP support). I made it under Windows 7 32 and Visual Studio 2010 for OpenCV 2.4.3.

It requires Windows version of CMake which will make a folder with Visual Studio solution and project files.

Then I compiled a solution (40+ projects) and made some settings in Windows Control Panel for OpenCV and IPP.

Adding IPP functionality to project with OpenCV usage did not make any problem (just uncomment "#define HAVE_IPP 1" in OpenCV configuration header file).

Your environment is very hard (win 8.1 64, MS VS 2013)

My suggestion: At first try just to compile OpenCV without IPP functionality adding.

Best regards,


Leave a Comment

Please sign in to add a comment. Not a member? Join today