mpicc -mmic - skipping when searching for -lmpigf

mpicc -mmic - skipping when searching for -lmpigf

Dear all,

I have a system with two Intel Xeon Phi. I've successfully configured them following your manuals and now I'm about to try to compile a simple example of mpi code in order to check if everything actually works.

On the sytem I've installed the following Intel tools: l_ccompxe_2013.2.146, l_fcompxe_2013.2.146, l_mpi_p_4.1.0.030

Then I've set

source /opt/intel/composer_xe_2013.2.146/bin/ intel64

source /opt/intel/impi/ 

So I tried to compile my mpi example as follows to run on the Phi cards:

./mpicc -mmic /opt/hello.c -o /opt/hello.mic

but it returned this error:

/usr/bin/ld: skipping incompatible /opt/intel/impi/ when searching for -lmpigf
/usr/bin/ld: skipping incompatible /opt/intel/impi/ when searching for -lmpigf
/usr/bin/ld: cannot find -lmpigf
collect2: ld returned 1 exit status

How can I solve this problem? 

I got that error also compiling the script without the -mmic flag and using the mpicc under /opt/intel/impi/ with -mmic

Here's the output of my $PATH and $LD_LIBRARY_PATH

echo $PATH


Thank you very much in advance for your support!


3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

As far as I know, no one has set up gfortran to support MIC, while the mpicc, mpif77 and mpif90  refer to gcc/gfortran, as they would with Intel MPI for host, even though there isn't satisfactory support for these on MIC. gcc for MIC is rudimentary, with no vectorization.

So you must use mpiicc when compiling with icc -mmic.  Several customers have complained about this; it can be worked around by setting up so that users who wish it can have mpicc as an alias for mpiicc (similarly with mpif90, ...).

Many applications on host can take advantage of interworking between icc and gcc (but not between ifort and gfortran); this isn't practical on MIC.

Dear Tim, 

thank you very much for your quick response!

As you said, using mpiicc -mmic I have no problem at all.

Thanks also for your explanation, it's actually very useful.

Best Regards

Leave a Comment

Please sign in to add a comment. Not a member? Join today