Windows* Early Enabling for Intel(R) Xeon Phi(tm) coprocessors - Now open to the public!

Windows* Early Enabling for Intel(R) Xeon Phi(tm) coprocessors - Now open to the public!

Windows* early enabling for Intel(R) Xeon Phi(tm) Coprocessors

We are excited to announce the release of Beta software drivers and development tools for you to run Windows* on Intel(R) Xeon(R) processor based hosts installed with Intel(R) Xeon Phi(tm) Coprocessors.

Intel has received many requests to support the Intel® Xeon Phi™ Coprocessor in a host system running Microsoft* Windows*.


We are excited to announce the release of Beta software drivers and development tools for you to try  in this environment!


We are making this software available early for those of you who indicated, that you want to invest time in pathfinding:  as stated above, the software and drivers are both Beta and the overall experience running with this platform combination is in an early stage.    Moreover, the Windows hosted model hasn’t been tested on many OEM hardware configurations, thus you might encounter problems on hardware we haven’t tested yet.


All of our documentation pertaining to this beta release can be found here:


-          Microsoft* Windows 7 Enterprise SP1 (64-bit), Windows 8 Enterprise (64-bit), Windows Server 2008 R2 SP1 (64-bit) and Windows Server 2012 (64-bit) are the versions that can run on the Intel® Xeon® processor based host containing the Intel® Xeon Phi™ Coprocessor.    The coprocessor will still be running a modified card OS based on Linux*.   This card OS will get installed when you apply the drivers (mentioned below)


-          Get Hardware:   Consult this list to see what OEM hardware providers sell systems with Intel® Xeon Phi™ Coprocessor.      If you are considering using a remote cluster, you can ask your remote cluster provider if they are willing to support a small grouping of systems with this configuration, but be aware this may not be possible.


-          Get development software and drivers:   The Beta drivers and development software that are validated against Windows 7 Enterprise SP1 or Windows Server 2008 R2 are available here.   Access to downloads and support  requires a registration


-          Learn more:   Consult this page regularly to monitor for more information becoming available (guides, BKMs, etc.).   This is where you will find instructions on how to get help.


-          Get support:    if your 3rd party software does not run on  Intel Xeon Phi Coprocessors, we encourage you to contact your software vendor  to let them know your needs.

If you run into issues with drivers or Intel development software, we ask that you characterize the issue as much as possible.    Instructions on where to take your issues or questions are provided here  


Because you are pioneering this  environment, we look forward to you collaborating with us  to ask questions related to this setup   and answer questions from others in the forum. 




14 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I faced a problem when install the driver.

When I double-click the file Intel Xeon Phi .msi, I got a error message "error 1324 the path Intel Many Integrated Core software contains an invalid character"

How to solve it?? The OS is Microsoft Windows server 2008 R2 SP1.


Hi Tinway,

is this a newly installed system with no known system or profile corruption?   The first thing to check would be the knowledge base article on Microsoft: 

can you also report the version and the size of the msi file you have - thank you

Hi Belinda,

I met the same issue as Tinway, and I am using Windows8 Enterprise 64 bit Traditional Chinese version, the version of MPSS is 2.1.6720 and size of msi file is 152,564KB.  The system is newly installed and no system or profile corruption.  And I tried the Microsoft KB document you referred to, no help.


Hi Tinway and Hunter,

Would you like to try this: login as an administartor, place the MPSS installer (.msi) in the administrator desktop directory (e.g., C:\Users\Administrator\Desktop) and then doucle-click the installer. Thanks.


I try to put .msi at administrator desktop directory but still fail, however I got the Windows Installer Log shows following:

"Error 2707. Target paths not created.  No path exists for entry SystemFolder in Directory table."

Seems it needs some directory exists to continue.


This issue has been reported to the build engineer. We will get back to you as soon as we can. Thanks.


We will update very soon the Windows MPSS with a better version (version 15). In the meanwhile, you can try the version 15 at

The correspnding documents can be found here:


Release Notes:

Please try this version to see if it works for you. But if it still doesn't work, please send us the MSI log along with the detailed information about your platform and the coprocessor card.


There is now a new, production release of the Intel(R) MPSS for Windows (no longer beta) based on Yocto.    Please read more at

Hi. Now I tried to download with GoogleChrome on Windows 7 Professional SP1 (x64), but my anti-virus software ESET NOD32 Antivirus BUSINESS EDITION said "2013/09/30 8:13:41(JST) Archbomb.ZIP - Trojan horse - isolated”. The virus database of the NOD32 is latest. Is there anyone with same trouble?

I am not able to reproduce this problem internally, but am also checking to see if others have any issues

Maki, can you tell me what antivirus software (and version / data version) you are using?

Hi Maki (et al):   Intel has tried to scan the windows zip file with a variety of antivirus software and has not been able to reproduce the problem.   Here is what we recommend:

1. Make sure the checksum of the file you've downloaded matches what we publish on the online documentation where you download -- in the current case it should be 23dbfcdff29fde6558d5ff675afdc2ce

If the checksum doesn't match, then some corruption has happened along the way -- we may need you to send us the file, along with some information (like 'traceroute') so that we can figure out if there is corruption at particular caching server(s)

2. There's a strong chance  that what you experienced here was a false-positive relating to how we packaged the microsoft installer in the zip file:  if the checksum is fine, is it possible for you to  report this issue to your antivirus vendor to ask them to correct this in their detection engine? 


Thank you very much for your effort. I also tried on my another PC with other antivirus software including Norton, TrendMicro, Kaspersky, McAfee, G Data and F-Secure, they reported that they detected no virus threat.

I've reported these facts to my antivirus vender, and today they replied to me "ESET(the vender) confirmed that it is a false-positive. It is corrected with update file 8893 and later."

Now I re-downloaded the zip file (md5sum is 23dbfcdff29fde6558d5ff675afdc2ce, same as you wrote) and scanned by ESET NOD32 Antivirus BUSINESS EDITION version 3.0.657.0 with the new update file 8893, it finally reported that it detected no virus threat.

Thank you.

Leave a Comment

Please sign in to add a comment. Not a member? Join today