Running sample code: offload error: cannot start process on the device 0 (error code 6)

Running sample code: offload error: cannot start process on the device 0 (error code 6)

Hello,

I have compiled the sample code using Intel(R) C Intel(R) 64 Compiler XE for applications running on Intel(R) 64, Version 13.1.3.192 Build 20130607 on a newly installed server with 2 phi cards

The code compiles OK, but gives an error upon running, see below

./intro_sampleC.out
offload error: cannot find MIC executable offload_main
Samples started
Checking for Intel(R) Xeon Phi(TM) (Target CPU) devices...

Number of Target devices installed: 2

Offload sections will execute on: Target CPU (offload mode)

offload error: cannot start process on the device 0 (error code 6)

        Flash Version          : 2.1.03.0386
        SMC Firmware Version     : 1.15.4830
        SMC Boot Loader Version     : 1.8.4326
micctrl -s
mic0: online (mode: linux image: /lib/firmware/mic/uos.img)
mic1: online (mode: linux image: /lib/firmware/mic/uos.img)

echo $LD_LIBRARY_PATH
/opt/intel/composer_xe_2013.5.192/lib/intel64:/opt/intel/composer_xe_2013.5.192/mpirt/lib/intel64:/opt/intel/composer_xe_2013.5.192/compiler/lib/intel64:/opt/intel/mic/coi/host-linux-release/lib

echo $PATH
/opt/intel/composer_xe_2013.5.192/bin/intel64:/opt/sge/bin:/opt/sge/bin/lx-amd64:/usr/lib64/qt-3.3/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/opt/intel/mic/bin

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Try setting the following env-variable and re-running:

MIC_LD_LIBRARY_PATH=/opt/intel/composer_xe_2013.5.192/compiler/lib/mic:/opt/intel/mic/coi/device-linux-release/lib:/opt/intel/mic/myo/lib

This one should have been set by sourcing the compilervars.sh/csh script.

Great, that works - thanks for the quick answer!

Glad that resolved it. Just curious, had you not source'd the compilervars.sh/csh script?  I just wanted to make sure there wasn't a malfunction with that.

Yes, sourcing the compilervars.sh works. I was using a "module load"  and didn't realise that the compilervars was not getting sourced by default.

Ah, ok understood. Wish you well going forward!

Leave a Comment

Please sign in to add a comment. Not a member? Join today