NFS problem connecting

NFS problem connecting

I've been following instructions from the latest Intel(R) Xeon Phi(TM) mpss_gold_update_3 README for NFS mounting to the Xeon Phi coprocessor (Section 7.6). After following all the steps, nothing seems mounted. When I try the "mount -a" command as root on the coprocessor, I get the error:

mount: RPC: Unable to receive; errno = No route to host
mount: mounting host:/srv/michome on /home failed: Bad file descriptor

When I look in the /etc/fstab on the coprocessor, the appended line from the document:

172.31.1.254:/mic0fs /mic0fs nfs rsize=8192,wsize=8192,nolock,intr 0 0 

has changed to:

host:/srv/michome    /home    nfs   nolock    1  1

All the options have been removed, the IP addres sof the host has been changed and the two zeros on the end are now each a 1.

Anyone have an idea about what I've done wrong? (I assume that the /mic0fs and /srv/michome directories are correct from the instructions.) Or, if everything has been done correctly, is there an easy way to test? (I put a file in the host /srv/michome/micuser directory, but don't see it on the coprocessor.)

--clay

 

P.S. Is the NFS mount required to use the Xeon Phi?

 

9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Did you exportfs the file system from the host side?

NFS mounts are not required, but for setting up permanent home directories on the coprocessor to supply ssh passcodes, it IS really convenient.

Yes, if it was in the instructions, I did it. I even went back and reviewed the instructions, performing the commands again this morning, after the system had been shutdown over the weekend.

This section of the readme has a few problems - the documentation has undergone a major revision for the next release which should help.

In the directions you were reading, "steps" 1 and 2 are describing NFS mounting /mic0fs on the host onto /mic0fs on the coprocessor. "Step" 3 is describing NFS mounting /srv/michome on the host onto /home on the coprocessor. So, these are actually two different things. To make things even more confusing, "steps" 1 and 2 describe a way of doing NFS mounting that doesn't survive beyond configuration updates and MPSS restarts.

So, the first question is: exactly what directory on the host is it that you want to mount onto the coprocessor? And where do you want to mount it to? The directories /mic0fs and /srv/michome are used as examples. On the systems I use, if I wanted to have the same home directories on the host and on the coprocessor, I would mount /home from the host onto /home on the coprocessor. Only you can determine what the names should be.

Then try following the directions in "step" 3, modified like this:

  1. Stop Intel(R) MPSS service
  2. IF THE HOST DIRECTORY YOU ARE EXPORTING WILL CONTAIN THE HOME DIRECTORIES FOR THE COPROCESSOR AND IF YOU HAVE NOT SET UP A "micuser" USER ON THE HOST: Set up micuser on the host and create required home directories in the exported directory with the correct file permissions and .ssh directory.
  3. Add the name of the exported directory to the /etc/exports file on the host
  4. Restart the NFS service
  5. Configure the coprocessor fstab file using the micctrl command "sudo micctrl --addnfs=<host_directory_name> --dir=<coprocessor_mount_point>" and "sudo micctrl --resetconfig"
  6. Check the fstab file to make sure it looks like you expect (you might want to change some of the mount options) by editing the file /opt/intel/mic/filesystem/mic0/etc/fstab (change the mic0 to match the coprocessor you are interested in) NOTE: this location is changing with the next release!
  7. Start the mpss

No soap. I tried the above revised set of instruction to mount the host /home on the coprocessor /home, but nothing semed to work. At least, whenever I reached then end of the list of commands and logged into the mic0, the home directory was always the same.

The coprocessor copy of /etc/fstab looked good, but I kept getting the same eror as before (with the new directories) when I issue the "mount -a" command as root on the coprocessor. I recreated the micuser accont on the host and reinitialized the ssh keys, but still nothing.

Any other suggestions or some steps I can use to ensure I'm starting with a "blank" slate with respect to the NFS idea?

I have the same problem.  Since the NFS is already set up,  we should be able to mount it with 'mount' command issued from coprocessor.  But the mount command complains that there is no route to host for RPC.  I have already open the port for RPC and NFS, and shutdown the NetManager as hinted by the User Manual.  Unless I am missing something, there is  a bug.

Since RPC cannot get to the host, the NFS never started.

Has anyone actually getting NFS to work on 3.1?

It turns out I didn't open the ports correctly.  When I disable the firewall. it works.

 

i resolve this issue with yast2. I open nfs server module and configure from it. I open yast2 firewall and add "NFS server" and delete ports 111 and 2049. That fix the problem.

James and Samoa,

Thanks for letting us know.

--
Taylor
 

Leave a Comment

Please sign in to add a comment. Not a member? Join today