Cannot udpate the flash/smc the mpss 3.1

Cannot udpate the flash/smc the mpss 3.1

In the readme of mpss 3.1, it mentioned that the flash should be updated otherwise might encounter stranage problem.

Then I tried to update my mic card, but it failed to update SMC and then get into 'failed resetting'  status.  What I can do to solve this issue?

micflash -getversion -device 0
mic0: Flash read started
mic0: Read done
mic0: Version:
mic0: Transitioning to ready state

# micflash -update /usr/share/mpss/flash -device 0
mic0: Flash image: /usr/share/mpss/flash/EXT_HP2_B1_0386-03.rom.smc
mic0: Flash update started
mic0: Flash update done
mic0: SMC update started
micflash: mic0: Flash operation timed out

mic0: Transitioning to ready state

Please restart host for flash changes to take effect

# micctrl -s
mic0: reset failed
mic1: online (mode: linux image: /usr/share/mpss/boot/bzImage-knightscorner)

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Not being able to get the flash to update properly has been an issue with you for some time. Have you tried power cycling the host (actually pull the plug - make sure their is no power to the card at all, then retrying the flash as explained in the last post to

If that doesn't work, did the flash update to mic1 work? If yes, have you tried swapping the ports these cards are connected to and try again?


Thanks for your reply.

I tried to power off, wait a while and power on, it could resolve the issue of mic card hanging at 'reset failed'.

If the 'power recycle' (pull and plug cable) takes much difference with 'power off', I'll try it later since my machines are in remote.

Leave a Comment

Please sign in to add a comment. Not a member? Join today